Warning bar, white text on white background

Hi All

I’d appreciate any help with this. I’m using kicad 5.99 on ubuntu 18.04. Any warnings that appear under the top menu bar are showing with white text on a white background. I’ve done some google searches and can’t find the error repeated anywhere else, the closest I can find is similar behavior with tool-tips. Any fix?

The default is white on grey. Could GNOME be messing with the colour scheme? especially as the tool selection colour is orange while it is blue for me

I’m guessing so, Kicad is fairly smart in terms of how it looks on each platform. I believe its coded to have a native feel. I just have no idea how to change it.

Maybe you have forced dark theme in Preferences -> Common, or KiCad somehow detects the theme incorrectly. Your icon theme is for dark background. However, when I change the theme to Dark it doesn’t change the infobar text color to light, so manually changing the icon theme shouldn’t affect the infobar.

If you look at the other tools it appears kicad has switched to DARK theme, which would make sense if the theme reported it was DARK

Maybe something dodgy in the theme. Either way in kicad options there is the ability to choose LIGHT,DARK,AUTO

try forcing lighr

I had it set (for some reason) to dark theme. But changing to lite or auto hasn’t made a difference as far as the info-bar is concerned.

The window color theme is detected automatically based on how bright the background color is. It is strange to have a dark theme detected with this bright background.

Absolutely everything else is working fine, just this. Its not a major issue for me as it can be read with a bit if squinting. But would be nice to get it working 100%. Any ideas on how to fix?