VRML Export to Blender - Tracks not shown

Hello folks,

Some time ago I wrote a program in Blender to import VRML PCBs from KiCad. I wanted to look at this project again recently. Unfortunately it seems that something has changed in the export from KiCad and I have some problems with the soldermask. When I import a VRLM PCB now, the tracks are no longer displayed on the soldermask. Also some free surfaces on F.Mask and B.Mask are not displayed. So far it worked, now unfortunately not anymore. The exports also no longer have any colour. I have not found a setting to change anything on the export. Can someone please help me?

Thanks in advance!

Maybe you CAN try KiCADStepUp plugin in The FreeCAD.

Hello xzf16,

thanks for your reply! The KiCADStepUp plugin for FreeCAD did not solve the problem, but a whole reinstallation of KiCad did. After the reinstallation the export worked as panned, also the color was there again. In blender, it makes a big difference which render engine is used (EEVEE or Cycles), because it has a big impact on how the “Alpha” of shaders is displayed.


is there a repository where your code is available?

do you have an howto video or similar for the recent version of Blender?

1 Like

Hey @maui,

the program is far from ready, and I’m pretty busy at the moment. I’m working with Fusion 360/Eagle most of the time, and the program fuses 3D-parts from eagle with the PCB from KiCad. But also an automated import from KiCad alone is possible. I try to invest some time soon and will let you know.

Best regards

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.