View zooms while I press middle mouse button

Hello,

I am new to kicad here! Using kicad 4.0.0-rc2 on windows7

Maybe I am doing something wrong. When I press the middle mouse button to pan the view, it also zooms out the view. If i do it really carefully, i can pan, but it is quite annoying. I have a logitech g9 gaming mouse.

how can I fix it?

Thank you very much!

Stop turning the wheel / get a better mouse?

I had the same annoying prob in windows…
I switched to Arc Touch Mouse
it has not a wheel but a touch surface, so it is easier to handle zooming and panning
or a trick is to move the mouse where you want to pan and press F1 or F2 to zoom…
that will zoom and pan where the pointer is…

When we answer questions like this, we turn people away from KiCad.

I agree that the middle button behavior is poorly implemented for mice with scroll wheels. I wish I had a fix I could give you, derethor, but I don’t.

Uh… my mouse is doing the same and is a Logitech M505 that had been in use for like 2 years now.
Really thought the mechanic/switch in there were the problem, but if others have this too?!

When I want to pan it sometimes also zooms out until the furthest distance.
Looking at this more closely now I found that my mouse wheel pushed right/left (horizontal scrolling) is zooming in/out as well, so not just turning it zooms the view, but pushing right/left does the same.
No wonder it runs towards the stops when I have this problem.
If I could deactivate this in the options I’m pretty sure I could get rid of this problem (zooming while panning) and only allow zooming from wheel turning only, not from left/right wiggling.

Ok, i will try with this. I saw that pressing F4 and holding it does the trick

But I guess that it would be great if we can configure the mapping of keys and actions. Maybe open a request/ticket for a future implementation?

thank you for your answers on this.

I suspect the “gamer mouse” has ridiculous dpi settings.

My old mouse has a mouse-wheel without indentations (worn out), it spins freely. I have no problems whatsoever with panning.

The trick is to press the wheel the right way, not in the center, but at the edge. That way the finger tip partially rests on the wheel and the mouse’s body. No spinning.

Edit: this may not help much if the wheel has intentional side-to-side wobbly-ness and zooms that way as well.

Isn’t this mouse-driver territory? Gamer-mice usually come with fancy setup programs to do all sorts of stuff. Maybe reduce dpi settings or turn off the side-to-side scrolling if the wheel has it?

The problem is not that I lightly move the wheel. It is that while you press the button, kicad keeps reading the wheel down status, and zooming out, when I am not scrolling my finger down.

We can try to find a mouse that it does not move the wheel when I press the button, but then, How can I zoom while I pan?

Hm. Then this must be a windows-only issue. I can press the mouse-wheel-button all I want and it only pans.

Edit: checked “kicad-product-r6311.a356293-i686.exe” with XP (VM), same thing. It works as expected. Not sure what to blame now.

one tap on surface and you pan, then you can swipe your finger to zoom in and out

moreover in general, if you move your mouse to a new position and then you zoom, pcbnew auto pan on that position, zooming exactly on your mouse new position… :slight_smile:

[edit] I think I’m talking 3d viewer here mostly and re-reading the thread this was more about eeschema/pcbnew… so disregard me as noise please. I’ll still leave it here just in case someone finds it interesting to read…

Well, for that matter I wish it would work more like in Autodesk Inventor…
There you got tools to select if you want to move (pan) or rotate (orbit) with the left mouse button, the wheel is always bound to zoom.
The cool thing about the rotate (orbit) function in Inventor is, that when you only click on the object within the white circle that is visible on the screen while the orbit tool is active, the point where the mouse-pointer ‘hits’ the object becomes your new pivot point for rotating… this is rather irritating in KiCADs 3d view, as this pivot point is always in the center of the board and you can never rotate around a spot of interest when zoomed in on the periphery of a board as the rotation pivot point is way outside of your scope and moves the area of interest out of view very fast.
The other nice thing is if you click and rotate outside of that white circle the rotation axis is perpendicular to the screen in the center of the circle.

Just tested to use the middle button while I had the orbit tool active and I got the move (pan) functionality… without any hiccups like in KiCAD. Though the middle button is harder to press on all mice I had so far, so I don’t use that functionality at all.
I’d rather look forward to get me something like this some day:

http://ecx.images-amazon.com/images/I/417Vll2NOSL.SY300.jpg

I simply configured my (Logitech) mouse so that that the thumb-button functions as middle-click. Works like a charm and it took me about 10 minutes to get used to panning with the thumb.

2 Likes

I also really would love SpaceNavigator support, and this seems to be the only reference of it in KiCad land anywhere. Are there any other eyes on this? I have no idea even where to begin hacking on it, all I know is KiCad’s navigation is terrible in comparison to basically everything else (altium with space navigator support, eagle with support for multitouch pads…)

Well, I ordered me a spacemouse some time ago, should nearly be at my doorstep - will see how I fare with it in CAD and how big a desire I develop to have something like that in KiCAD :wink:

I’m having this issue with my mouse as well - is there a way to disable the handlers for horizontal scrolling? Currently both horizontal and vertical scroll events trigger zooming, and I don’t need both. It’s tricky to press the wheel (which is my middle button) without also rocking it a little left or right.

I seconds ssfrr and others. IF a mouse supports horizontal scrolling then it makes middle button unusable. On windows and with Logitech mouse I was able to deactivate horizontal scrolling specifically for KiCad using Logitech Options software, but would also like to know if there is a way to deactivate it in KiCad itself.