Video problem version 6.0.5

My very first post her and unfortunately about a video problem. I have tried KiCad in the past and never had a problem. Yesterday I decided to switch to KiCad permanently and downloaded 6.0.5. At start-up the field of the schematic editor and Gerber viewer were blurred. The menu around the fields were OK.
I did some Googling but, to be honest, I didn’t even know what to look for exactly. But I did find the post about the OpenGL problem. That person mentioned that version 5 worked fine so I downloaded the 5.11 Lite version and that one works on my laptop.
I have an Acer Aspire with a NVidea GeForce MX250 running Windows 10. If you need more info, please ask but tell also how to find the needed info.

I hope someone can help me. Many thanks in advance!

Kind regards, Ruud Baltissen

www.baltissen.org

Hello and welcome @Ruud

To post full information: open Kicad, then Help / About Kicad / Copy version information (top left corner)
then just paste.

Here it is:

Application: KiCad (64-bit)

Version: (6.0.5), release build

Libraries:
wxWidgets 3.1.5
libcurl/7.82.0-DEV Schannel zlib/1.2.12

Platform: Windows 10 (build 19044), 64-bit edition, 64 bit, Little endian, wxMSW

Build Info:
Date: May 3 2022 00:36:16
wxWidgets: 3.1.5 (wchar_t,wx containers)
Boost: 1.79.0
OCC: 7.6.0
Curl: 7.82.0-DEV
ngspice: 36
Compiler: Visual C++ 1929 without C++ ABI

Build settings:
KICAD_USE_OCC=ON
KICAD_SPICE=ON

Is there a way to insert an image? You can download a small PNG (6 KB) that shows the right-bottom part of the editor screen: http://baltissen.org/temp/KiCad6.png

Many thanks in advance!

Kind regards, Ruud

Hi @Ruud
I have a similar (or may be exactly the same) problem on my Toshiba laptop running Win10. It’s not my main Kicad machine so what I did is: go to Preferences, Display Options, Rendering Engine and there I switched from Accelerated to Fallback graphics. Works for me on that laptop :wink: My projects are not huge, so I don’t see the significant difference. Hope this will help …

^^^This.
Works for me as well and doesn’t really bring any downsides. The graphics rendering changed between 5.x and 6.x.
.

Hello Goran and ML9104,

The procedure you describe doesn’t fit. I click Preferences at the top-left, 4th item. I get a submenu with again Preferences, also 4th item again. Then I get a rectangle with various options but nothing like Display Options or Rendering Engine. Do I miss something?

There is a rectangle Antialiasing containing a line with Accelerated graphics and one with Fallback graphics. Both have been set to No Antialiasing. I don’t see any means to select one so I have no idea how to switch.

Changing the value of Fallback graphics doesn’t change things. Changing the value of Accelerated graphics make things even worse.

Should I uninstall KiCad and give it another try?

Thank you for any help!

Kind regards, Ruud

Hi @Ruud
EDIT: Sorry, Preferences / Preferences from Project Manager or Preferences from Schematic .

Preferences then 1st line under Symbol Editor and also under Schematic Editor. In both cases it reads Display Options. Top of the new window in each case reads Rendering Engine.
You can choose Accelerated or Fallback.

Hello jmk,

THAT worked out fine. Thank you very much !!!

Kind regards, Ruud Baltissen

1 Like