Vias in polygons

Kicad 5.99 - I am NEW to Kicad and PCB cad in general. First board ever in any CAD. I have some high current traces that cannot be simply drawn but must be polygons - top and bottom on 2 layer board. Everything is fine EXCEPT I cannot stitch them together with vias. I tried turning off the “avoid vias” and all other stuff in the polygon properties with no help - in fact even if I save they come right back. If I try to insert vias I get “violates DRC” which I would turn off if it would let me. How is this done?

When you create new zones – note zones, not just copper polygons – you attach them to a net in the zone’s properties dialog. When you have zones in the same net in the opposite sides of the board and add a new via, the via should receive the same net automatically.

See also How to create a power plane (using zones).