Via stitching and power pads: I can't change netname of pad

The discussion on via stitching is very helpful.

However, when I try to do it, I cannot change the netname (e.g. to GND). Without changing the netname to the zone’s net, my gerbers seem to contain very thin gaps between a zone and the via pads, even if I set the zone connection (in the footprint and/or pad) to SOLID. The gap does not show up at all zoom levels in Gerbview, so I don’t know how “real” it is or if it is essentially a 0 width gap.

I have tried all sorts of combinations for entering netname: using square brackets, using / prefix, using sheetname prefix, using net number from View/List Nets… I have tried copying netnames from other connected pads using cut and paste. It always just pops up an error box that says: Unknown netname, netname not changed

I have a similar problem if I add a “power pad” to a footprint such as a FET. I can disable DRC and get the part with pad placed and connected. But I cannot set the netname for the power pad, and it does not seem 100% connected to a surrounding zone in the gerbers.

Can someone tell me the secret? Thank you!

BTW I am using Build 2014-jan-25, which is the newest stable build available on PCLinuxOS. The people at PCLOS have been strikingly unhelpful about getting newer versions into the distro. I am VERY hesitant to move to 4.0 until it is proven, as I know how to work around most of the older quirks!

Post a stripped down board file please.

It appears this is a problem specific to this version. I have 2013-jul-07 on another machine under Mint. It operates as I would expect and I can change net names there.

Hopefully I can soon move to 4.0+ so no need to pursue this issue.