Via pads missing when printing

Hi all,

using the git version of Kicad, for some reason the via pads are missing if I print using the print dialog, while on the plotted images they are present as expected. What is the reason for this, am I missing some setting, or is it a bug?

Printed:
printed-F_Cu

printed-B_Cu

Plotted the same:
plotted-F_Cu

plotted-B_Cu

Probably a bug. Report it in the bug tracker https://gitlab.com/kicad/code/kicad/issues. Remember to copy and paste the version information from Help->About->Copy Version Info (saying “git version” or “the latest” isn’t enough).

Print and Plot are different.
The Print dialog has a Drill marks option with “No drill mark, Small mark and Real drill”.

Maybe yours was set to “No drill mark”.

It was set to “Small mark”, but the pads won’t be printed regardless of how I set this option.

Drill mark is the spot in the middle of the via where the mask should be actually missing, so the “Drill mark” option should not affect whether the pad itself is printed or not.

I’m not sure if it makes sense to not print the pads and there doesn’t seem to be any option to control that.

Then it could be a bug.
Anyway I only use the print function when I want to see more than one layer on the same file.
For printing I always use plot, sometimes to pdf and mostly to gerber.

I can confirm this bug ( 5.99.0-807 still there). Did you report the bug ? I can’t find it in issues list…
My problem is, that I need a pdf printed in A5 size. I can select printing size in the print dialog, but not in
the plot settings. So. I can’t use print due to this bug and can’t use plot due to missing pdf settings :frowning:

File -> Page Settings

Have you tried that to see if it makes a difference?

@kulturgueterschuppen
When you go to File->Page Settings, you can’t select A5 but you could select User (Custom) and then configure the size as an A5. Would that not work for you?

thanks a lot , Hermit and Johannes, that worked !

1 Like

I’m pretty late, but reported it now at

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.