Version from Flathub won't install, obsolete platform dependency

I just tried installing KiCAD via flathub on debian stretch, and it won#t install because org.gnome.Platform/x86_64/3.26 seems to be no longer available:

~$ flatpak install --from
Installing: org.kicad_pcb.KiCad/x86_64/stable
Required runtime for org.kicad_pcb.KiCad/x86_64/stable (org.gnome.Platform/x86_64/3.26) is not installed, searching…
Found in remote flathub, do you want to install it? [y/n]: y
Installing: org.gnome.Platform/x86_64/3.26 from flathub

_1 metadata, 0 content objects fetched; 569 B transferred in 1 seconds _
Fehler: GDBus.Error:org.freedesktop.DBus.Error.Failed: Error deploying: While trying to checkout d01b14e467c27c7f0991699bd8ae6801a72bd178232705f15384520ee45ff738 into /var/lib/flatpak/runtime/org.gnome.Platform/x86_64/3.26/.d01b14e467c27c7f0991699bd8ae6801a72bd178232705f15384520ee45ff738-FZMJXZ: Keine Daten verfügbar


Last time I was running FreeCAD on my Debian / Buster box it was from a direct download from freecadweb / github
I would prefer to simply get recent versions with apt, but you take what you get and be thankfull for it.

Why are you posting a FreeCAD link for a KiCAD question?
Also FreeCAD from flathub works.

Why are you posting FreeCAD questions on the KiCad forum?
I’m confused.
After reading through the unreadable pathnames it seems your initial FreeCAD remark is either misleading or a typo?

Stretch seems to want to install kicad (4.0.5+dfsg1-4)

which is becoming a bit old.
Personally I’m quite content with Debian / Buster. Buster is up to date with KiCad V5.0.2

On the KiCad site there seems to be a linkt to a backport of KiCad V5.0.1 for Debian Stretch:
Which links to:
Is that usefull for you?

Sorry about that, fixed it.
But the rest of my error message shows I tried to install kicad.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.