Version 5rc2 issue


#1

Version: (5.0.0-rc2-dev-720-g9704891c8), release build on Windows 7:
Tried to load rather complex board.
Selected cia_acc.pro for the test from here:


When invoked, the PCB Layout editor showed empty page.
I was able to get PCB displayed after switching to Legacy Toolset.
Switching back to Modern Toolset showed nothing again.

I haven’t installed my Linux machine yet so I can’t comment,
how does the Pcbnew handle this board on Linux.

Note that my very simple 2 layer board with few components is displayed correctly
in Modern Toolset mode.

Cheers,
Mihal


#2

Disclaimer: Kicad 5.0.0-rc2 has not yet been released. You run a normal nightly build from some time after the rc1 tag has been set in the kicad source directory.


I can not replicate the behavior you describe in todays ubuntu nightly build.
The pcb renders in all 3 canvas options.


My kicad version:

Application: kicad
Version: 5.0.0-rc2-dev-unknown-86d6ed5~65~ubuntu16.04.1, release build
Libraries:
    wxWidgets 3.0.2
    libcurl/7.47.0 OpenSSL/1.0.2g zlib/1.2.8 libidn/1.32 librtmp/2.3
Platform: Linux 4.13.0-41-generic x86_64, 64 bit, Little endian, wxGTK
Build Info:
    wxWidgets: 3.0.2 (wchar_t,wx containers,compatible with 2.8) GTK+ 2.24
    Boost: 1.58.0
    OpenCASCADE Community Edition: 6.8.0
    Curl: 7.47.0
    Compiler: GCC 5.4.0 with C++ ABI 1009

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_WXPYTHON=OFF
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=ON

#3

Yes, it it nightly build that says that it is rc2:
Application: kicad
Version: (5.0.0-rc2-dev-720-g9704891c8), release build
Libraries:
wxWidgets 3.0.3
libcurl/7.54.1 OpenSSL/1.0.2l zlib/1.2.11 libssh2/1.8.0
nghttp2/1.23.1 librtmp/2.3
Platform: Windows 7 (build 7601, Service Pack 1), 64-bit edition, 64
bit, Little endian, wxMSW
Build Info:
wxWidgets: 3.0.3 (wchar_t,wx containers,compatible with 2.8)
Boost: 1.60.0
OpenCASCADE Community Edition: 6.8.0
Curl: 7.54.1
Compiler: GCC 7.1.0 with C++ ABI 1011
Build settings:
USE_WX_GRAPHICS_CONTEXT=OFF
USE_WX_OVERLAY=OFF
KICAD_SCRIPTING=ON
KICAD_SCRIPTING_MODULES=ON
KICAD_SCRIPTING_WXPYTHON=ON
KICAD_SCRIPTING_ACTION_MENU=ON
BUILD_GITHUB_PLUGIN=ON
KICAD_USE_OCE=ON
KICAD_USE_OCC=OFF
KICAD_SPICE=ON
But anyway, I just wanted to give it a try so I chose that
relatively complex board for the test.
As my production machine is W7, I tested it on W7…
I will install debian on my ancient I5-2500K/ATI5830 and will test
it there.


#4

I do not know how complex the CIAA board is, but how does it compare to the Olimexino64?
https://github.com/OLIMEX/OLINUXINO/tree/master/HARDWARE/A64-OLinuXino

Olimexino A64 is an ARM board with DDR3 at somewhere around a Ghz clock frequency.
A bit similar to the “better known” Raspberry pi.

Oops:
Just browsed through: http://kicad-pcb.org/made-with-kicad/ and CIAA is also there, but I see several PCB’s with different complexity.


#5

Version: (5.0.0-rc2-dev-720-g9704891c8), release build

This is on the RC2 Development branch. However, RC2 has not yet been released.

That commit signature is from early Saturday, May 12th. There have been 16 commits on the same development branch since then. I suggest installing a later build and see if that problem has been resolved. If not, file a bug report.


#6

Same with: “Version: (5.0.0-rc2-dev-733-g23a9fcd91), release build” windows nightly build.
I will fill bugreport as soon as I figure out, how to do that.
Mihal


#7

Working for me on Windows 10 with r10320


#8

I just installed it on my dual xeon / 40 GB RAM / some entry level Nvidia graphics card desktop PC
and I have to confirm, that the CIAA-ACC board works there.
OS is Windows 7 Pro 64 bit.
So it seems that the problem lies most likely somewhere in my Lenovo 531 notebook.
It is equipped with i7-3632QM processor and Intel graphics (no accelerated addon Nvidia or ATI card)
and 12GB RAM.


#9

Then it’s time to chase tools that will tell you what OpenGL version is available and what your hardware supports…


#10

Mine is a Lenovo Thinkpad 13 with i5-7200
Check your video driver is working, support OpenGL to a reasonable level and how much RAM is set for the shared video. That is a very complex and dense board


#11

you may try with Modern Fallback option [F12], instead of Accelerated [F11] one…
modern

12 layers :wink:


#12

Thanks all for help and suggestions.
BTW anyone tried to zoom in/out that on that board?
At the certain level KiCad is not much responsive, even accelerated…
It helped to minimize number of visible layers though…,
My graphic card is GeForce GTX 1050 with 2GB of RAM (which is entry level card)
My system is dual X5690 Xeon with 40 GB of RAM and “not so slow” (550 MB in both directions) SSD.
Except the graphic card, there isn’t much to upgrade…
Do you think that it would improve KiCad’s responsiveness?


#13

Some of the developers had been asking about suitable complex boards for stress testing. This is a good candidate.


#14

Yes, it definitely is :slight_smile:.
BTW Olinnuxino64, despite having only 6 layers,
also doesn’t zoom smoothly when everything is fully visible…


#15

are you sure kicad is using the GeForce drivers? (see the GPU activity)


#16

It’s windows box so it should…


#17

you need to have the OpenGL drivers installed and running (not the DirectX ones…)
NVidia gives you also a control panel to get detailed info.


#18

Here:


NVIDIA says:
OpenGL 4.6 and GLSL 4.60 are now supported by all the latest NVIDIA general release display drivers

So, although my driver wasn’t outdated, I installed the very latest driver
and based on the nvidia sentence above, I should have opengl driver installed as well.
But the nvidia control panel doesn’t mention a word about opengl.
It says something about directx 11.0.

Nevertheless, how and where can I select that KiCad uses opengl drivers?
In KiCad application? In some text config file? In registry? In display driver config?


#19

By selecting the canvas “modern with acceleration” (F11).
But this canvas automatically switches back to “modern fallback” if there is some problem with opengl. So you would most likely want some test tool to see if opengl does indeed work on your system.


#20

if they are up and running your apps will use directly…
NVidia has already a tool to check it…
gpu-tools

anyway you can use also this tool (not tested myself, I use the NVidia control panel)