Value on SilkScreen not exported to Gerber files

Hi all,

I know v6 doesn’t get much attention now. I’ll probably will upgrade to v7 soon.

However I thought it’s worth asking here.
Not sure if this is a bug or I need to tick some options in setting to make it work.

Seems like a value field when changed from a default Fab layer to SilkScreen is shows up in 3D viewer, but it’s not exported to Gerbers.

Steps to replicate the issue:

  1. insert a footprint to a PCB editor (in my case I use “SolderJumper_3_Open”, but noticed that yesterday on any footprints)

  2. change to value field (the default is “SolderJumper_3_Open”) from Fab to SilkScreen, make sure visible is still ticked. change the Ref field (JP1) to Fab layer.

  3. It shows up correctly in PCB Editor and 3D viewer as below:

  4. export PCB to Gerber files and open in Gerber Viewer

  5. The result is as below. “JP1” is not visible (on Fab layer, so this is correct), but also “SolderJumper_3_Open” is not visible, but should be on SilkScreen layer (so this is a wrong behaviour)

Version info:

Application: KiCad (64-bit)

Version: (6.0.10), release build

wxWidgets 3.2.1
libcurl/7.86.0-DEV Schannel zlib/1.2.13

Platform: Windows 10 (build 19045), 64-bit edition, 64 bit, Little endian, wxMSW

Build Info:
Date: Dec 19 2022 21:23:04
wxWidgets: 3.2.1 (wchar_t,wx containers)
Boost: 1.80.0
OCC: 7.6.2
Curl: 7.86.0-DEV
ngspice: 38
Compiler: Visual C++ 1929 without C++ ABI

Build settings:

Also behaving the same on my home Linux machine (Ubuntu, same KiCAD version - 6.0.10).

Is this a bug or I missed something in the settings?

gerber export dialog: check option “Plot footprint values”
(above the “Plot reference designators option”)

1 Like

Many thanks. It works.