V7 harder to run for the first time than V6 was

Today I installed V7.0.1.
Only the fourth attempt to start using it was successful.
Attempt 1.

  • I select to import settings from V6 (…kicad\6.0),
  • I say no to automatic data collection (PC with KiCad is not on-line),
  • File-Open and select one of my V6 projects,
  • no check for Plugins,
  • click ‘Schematic Editor’

and here problem begins.
As I already told KiCad to use my V6 settings then I understood than in V6 my default library was what I want now so I accepted recommended selection to use default - error (my mistake) - it is not what I wanted.
Attempt 2.
So I delete 7.0 from Roaming\kicad and do everything once more.
This time I select ‘Copy custom global symbol library table’.
As I have previously told KiCad to use my V6 settings than I assume that it knows where from to take my custom library table. I assume that box with ‘Select global … file’ is to allow me to specify the other place to store that file so not reading it I click OK. Once more - fail.
Attempt 3.
At that critical moment I decided to Browse for my old sym-lib-table.
But it looks being not possible. The opened window to select file don’t shows system or hidden files (I don’t know if in Win10 …AppData\Roaming is system or hidden) and I don’t see the way to see them in the opened by KiCad window).
So I failed for the next time.
Attempt 4.
I have copied from Roaming\kicad\6.0 directory sym-lib-table to directory I know is not system and not hidden.
This time I was able to select it.

May be some fails is my fault.
I don’t remember such problems when running V6 for the first time.
Those time I had not to copy sym-lib-table anywhere (or my memory is so bad).

It is probably the problem with my memory.
With V6 I had PC with Win10 just set up so I had Roaming\kicad copied from previous PC at pendrive (and also copied it onto C: to be find by KiCad). Pendrive was still in so I just use Browse and selected that file from pendrive.
Today first time I also tried to Browse but not seeing the file to select and remembering that I had not problems previously I have tied all possibilities not needing to find that file first.

Do at other systems that window opened by KiCad to select file shows contents of KiCad configuration directory?

There are some valid points here that I would boil down to this:

  1. KiCad doesn’t make it very clear that “import settings from v6” does not mean “import libraries”. You have to separately instruct kicad to do that by pointing to old lib table files.
  2. On windows (and some linux interfaces) it’s hard to navigate to old settings folder because it’s hidden. Average user doesn’t even know where their kicad global settings are without googling it.

Here’s a tip that would have helped you on attempt #3: click the address bar of the open file dialog and enter %appdata%, press enter. Explorer windows understand environment variables, that will take you directly to your ...\AppData\Roaming folder where kicad’s settings are.


You can also merge the sym-lib-table and fp-lib-table files with a text editor or a source code comparison program.

1 Like

It is surprising for me as library lists are for me the main configuration to be copied from previous version.
Now (after consideration) I understand that it is divided into separate applications. But when I run KiCad V7 for the first time and just told it that I want to use V6 configuration than I am surprised that during few seconds KiCad forgot it.
In my opinion it should:

  • copy library file lists when I told to use V6 configuration (it is a part of configuration, isn’t it), or
  • write that information somewhere in configuration to not ask me to find those files myself, but just ask if to use lists from V6 configuration (KiCad knows better where it is than many its users I think).
    If configuration is located ‘somewhere’ that most users don’t know than why they suddenly should learn it when moving from V6 to V7? I see no arguments for this.

Didn’t know that and probably will shortly forget. I don’t use Explorer and I’m not familiar with mess made at HDD by Windows using its own names to name other disc locations. I use only direct addresses (also in KiCad). I just don’t know why use two names to name one place.
Many years ago we decided that we install Windows at C: and for our data we use D:. That allows if something with system is broken to format C: and reinstall it not touching our data.
We did it only few times. In meantime Windows got the possibilities to repair himself without need to reinstall it but if you get used to something…
Having all my data at D: allows me to see only ‘my’ directories. My only need to look at C: is when I need to do something with KiCad configuration files.

I need not to do any manipulations in those files. I just need to use the same as in V6.


If you use windows, you use explorer. System open file dialog is also an explorer window.

OK. Strictly logically you are right. I just newer use it intentionally (except just after installing Windows until I install FreeCommander).

I think there is also a problem with translations. Words can be ambiguous in meanings.

As an English First Language user, to me, configuration means Settings and the like. I wouldn’t consider Library importing as part of configuration, but the interpretation of the translation may well differ for certain English Second Language users.

Perhaps a re-wording of the instruction should be considered.

We are not speaking about library importing but about library lists.
For me library list is also ‘my configuration’ or ‘my settings’ as other parameters I have set.
Never tried, but since some time you probably can have few color sets to select from and it is a configuration. There is no difference in conception of having these colors set listed and libraries listed.

Libraries are included in KiCad (Windows) package and they are installed (copied) during KiCad installation. I have at PC both KiCad and my libraries so it is not a question which libraries to import. It is only a question which libraries to open and for me it is configuration.

Sorry, I misunderstood your question.