V599 issue with editing a particular Footprint

Version info at the end of this file.

This file was downloaded from SnapEDA. It had a number of added text entries I wanted to delete.

To reproduce:

With this file in you library:

  • Open it in the Symbol editor.
  • Delete (from the bottom, although it may not matter) the 8 text lines one at a time. I used the trash can icon to delete.
  • OK - window will close
  • Reopen the same footprint, presumable all the deleted text will be deleted, but it is not.
  • Delete the remaining text lines.
  • OK --> all open Kicad window disappear.
    Repeated it a few times.

I tried to put this on Gitlab but couldn’t find the correct area to post it.

ADUM5242ARZ.lib (985 Bytes)

Application: KiCad
Version: (5.99.0-1622-gbc24d8e95), release build
wxWidgets 3.0.4
libcurl/7.66.0 OpenSSL/1.1.1d (Schannel) zlib/1.2.11 brotli/1.0.7 libidn2/2.2.0 libpsl/0.21.0 (+libidn2/2.1.1) nghttp2/1.39.2
Platform: Windows 8 (build 9200), 64-bit edition, 64 bit, Little endian, wxMSW
Build Info:
Build date: May 10 2020 21:00:10
wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8)
Boost: 1.71.0
OpenCASCADE Community Edition: 6.9.1
Curl: 7.66.0
Compiler: GCC 9.2.0 with C++ ABI 1013

Build settings:

Does not compute.

The file is a symbol library file with a single component, but your screenshot is from the Footprint Editor ???

So I do not know which 8 lines to delete, because that info is not in the file.

All of KiCad’s files are (reasonably) easy to read ASCII. So if you have a problem with it, open it in a text editor and try to spot some “strangeness”.

At the moment I’m guessing you uploaded the symbol library file, while you wanted to upload the Footprint Library

Every text added to a footprint comes up there. So delete the texts in the canvas or accept that they are there.

Sorry I uploaded the wrong file.

ADUM5242ARZ.kicad_mod (6.2 KB)


My issue wasn’t their existence but that the symbol editor crashed trying to remove them

It’s still not the Symbol Editor. The screenshot is the Footprint Properties dialog, opened from the Footprint Editor.

I got it to crash, too. Please find the exactly repeatable steps (very exactly, so that the reader doesn’t try to do it in any other way - even the order of the lines may be important) and report this. A screencast would be great because it shows the steps without a mistake.


Yes on all counts. My only excuse was that I’m relatively new to Kicad (actually I’ve used Kicad before but forget almost everything in the year since) and I had been playing with two new IC’s where I was concerned the footprints might not be correct.

So I did have the issue in the Footprint editor. Do I understand you correctly that you experienced this crash as well? What can I do to help document this issue?


I have deleted all the fields and texts with 5.1.5 and 5.99 successfully.

I have deleted the items from the graphics of the footprint, not from the edit table.

Interesting, perhaps the error is in the table editing function. Did you use the same footprint as I uploaded? The thought had occurred to me that this footprint might have been corrupted or somehow different. Although I’ve not had the occasion to try to edit another footprint in this manor.

Yes, the same footprint




This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.