V5->V6 footprints keep pointing to wrong 3DMODEL directory

Hi everybody,

I installed Kicad V6 and opened (and implicitly converted) a V5 project.
Problem is now that the 3D models are not working anymore because all the
footprints in the layout editor have still “${KISYS3DMOD}/” in the 3D Model path.
In the schematic editor, all symbols refer to the (new) footprint directory and the preview
shows the 3D model. So everything’s fine there.
I tried to update the pcb from the schematic which makes no difference.
Both the schematic and layout editor are configured to use KICAD6_3DMODEL_DIR.
To confirm, I manually edited one footprint in the layout editor and replaced the string
“${KISYS3DMOD}/” with “${KICAD6_3DMODEL_DIR}”. After that, the 3D model popped up
in the 3D viewer. Of course, only for that component.

How can I fix this without manually editing all footprints?


Use Preferences > Configure Paths to define KISYS3DMOD to be the same as what KICAD6_3DMODEL_DIR is defined to be?

1 Like

Thanks, that did the trick!

Actually, the real solution is: layout editor → Tools → Update footprints from library
No need to define “KISYS3DMOD” in “configure path”.
Apparently, Update PCB from schematic does not update everything.

Sure, but then you risk mismatch between what you have and what’s in the library now. I know that some footprints changed name sllightly across versions. But I think I prefer to do update from library in the long term. But only on an as needed basis.

In a related issue I had a SOP-16 footprint in my design. When I migrated to v7, the 3D model disappeared. I discovered that the model is now associated with SOIC-16. Or something like that.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.