V5.99 The Four Main Applications are Scaled Incorrectly

Application: KiCad Footprint Editor

Version: 5.99.0-unknown-881cb3182b~117~ubuntu20.04.1, release build

Libraries:
wxWidgets 3.0.4
libcurl/7.68.0 OpenSSL/1.1.1f zlib/1.2.11 brotli/1.0.7 libidn2/2.2.0 libpsl/0.21.0 (+libidn2/2.2.0) libssh/0.9.3/openssl/zlib nghttp2/1.40.0 librtmp/2.3

Platform: Linux 5.4.0-65-generic x86_64, 64 bit, Little endian, wxGTK, mate, x11

Build Info:
Date: Feb 20 2021 08:06:23
wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 3.24
Boost: 1.71.0
OCC: 7.3.0
Curl: 7.68.0
ngspice: 31
Compiler: GCC 9.3.0 with C++ ABI 1013

Build settings:
KICAD_SCRIPTING=ON
KICAD_SCRIPTING_MODULES=ON
KICAD_SCRIPTING_PYTHON3=ON
KICAD_SCRIPTING_WXPYTHON=ON
KICAD_SCRIPTING_WXPYTHON_PHOENIX=ON
KICAD_SCRIPTING_ACTION_MENU=ON
KICAD_USE_OCC=ON
KICAD_SPICE=ON

Try adjusting Preferences -> Common -> User Interface -> Canvas Scale

Try 2.0

1 Like

Clicking the “Automatic” selection auto-scaled it to 2.0 canvas scale.

wxWidgets doesn’t properly detect screen DPI/scale factor in 3.0. They have fixed this issue in wx3.1 but it is not generally available for Linux distributions yet.

Until then, you will need to set your own scale rather than using the Automatic option.

1 Like

Uhhmmm? I set the value in the box to 1, then clicked the auto-button, and the number changed to 2. So, it seems to work on my particular build.

We also test for the GDK_SCALE environmental variable. Some distros set this properly and we can check for it.

edit:
OK, this discrepancy bugged me, so now we reach into GTK and get the data directly if the user asks for Automatic Scaling.

4 Likes