V5.99/13060 IC PIN not connected, but why?

I am migrating from a commercial application toward KiCad. To avoid a double learning curve started with v5.99 (aware of the risk). So far I have to say I like KiCad, easy to learn and mostly intuitive.

Just tried to create the first PCB and during placement I noticed that one pin of an 8 pin IC had no connection in layout, while it should be.
Design rule check does not list it as unconnected. In thh schematic it is clearly connected as well.

In layout the pad has the following text inside the pad:
Upper line=1 (which is pin number), lower line=“Net-(U1-Pad1)”

Lower line seems an incorrect netlist label. When I click the connected wire in the schematic it shows “ref” for the connection name, which seems correct.

It can be this is a 5.99 bug, but I wonder why only this pin ? Am I maybe doing something wrong ?

Any suggestions are welcome.

What’s the library symbol and the library footprint? Are they from the official KiCad libraries or somewhere else? Have you attach the footprint to the symbol yourself or was it predefined? Can you show readable screenshots of the relevant part of the schematic and the layout? (The whole component.)

Thanks for your reply. The schematic symbol I created myself based on an existing one.
The PCB footprint is an official one: Package_SO:SOIC-8_3.9x4.9mm_P1.27mm

The PIN which is not conneted is pin 1 (the connection between C1 and C2 does exist in PCB)

Attached screenshot of the schematic and PIN definition


Can you check that all 4 wires going into that 4-way junction above the GND symbol are actually connected and the same net? One way to check this would be to use the net highlight tool (2nd button down on the right side toolbar).

Net-(U1-Pad1) is an autogenerated net name for when a net doesn’t have an explicit name. But visually, it looks like it should be connected to GND correctly.

Attaching your project would also be helpful for debug.

All other connections of the junction above the ground symbol are ok. I tried the net highlight tool (not used before but helpful) and it highlights everything including pin 1 of the IC with its pin name.

Project is nothing confidential, just a first trial with KiCad, I attached an archive of the project. Maybe it clarifies something. esplayer32.zip (124.9 KB)

I do not think that there should be one, since from the symbol pin 8 is missing.

This is the pin table:


You need to reconfigure some pins as shown…

Edit: Why those double numbered pins with different names?

Your schematic symbol has multiple pins with pin number 1.
I spread some of the hidden pins a bit apart in the symbol editor to make them more visible:

In footprints you can have multiple pins with the same number (and then KiCad just wants you to connect them all together).

I’m not sure what KiCad makes of multiple pins with the same number in a schematic symbol.
I’m guessing that KiCad just picks one of them and ignores the others.
I had a look at Eeschema / File / Schematic Setup / Electrical Rules / Violation Severirty but I saw nothing about pins with the same number in a schematic symbol. Maybe this should be added to the ERC.

Learned a lesson from this: “always check the pin table when modifying an existing symbol”, or probably even better, always check the pin table before saving.

Running the ERC for the first time always leads me to another question, which is probably easy to answer. Does Kicad has a standard symbol to attach to unconnected pins ? Or do I have to create one myself ?

Actually there are two. One is a pin-type that you can set when designing a symbol, used for pins that the datasheet tell you to not connect to anything. The other is a no-connect symbol that you can add during schematic capture. Here is the button in the right-hand tool bar, and you can see me using it on the discharge pin of a 555 timer (the blue X is the no connect symbol):
2021-11-04 03_00_53-

I know that I have a symbol with a no connect pin, but I don’t remember off the top of my head which one to grab a screenshot for you.

BTW, my screenshot is from v5.1.10. The icon may look a little different in 5.99.

1 Like

Thanks, I feel a bit stupid. Looked in the toolbar could’t find it, looked in the symbol library could not find it. Used Google, found some discussions, but not clear where the symbol came
from. Actually it was just in the toolbar and I overlooked it :slight_smile:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.