V5.0.0-rc2 : PcbNew Track routing does not end while selecting end pad


#1

Hi Kicad Team !

Before reporting a bug I need to be sure I don’t make a mistake. I recently upgraded my Kicad version to 5.0.0~rc2+dfsg1-3 and I have a problem with PCBNew.

When a use the track routing tool :
-> Selecting the starting pad works well.
-> Accelerated interactive routing work well.
-> But when I select the end pad. Instead of finishing the route, Kicad add an intermediate point like when I click on the black background.

Is there a new thing to do to ending track on Kicad 5.0 ?

Note : My pads are through-holes with default size.

Regards,

Baptiste.


#2

Have you selected/unselected “Magnetic pads” in Preferences?


#3

Just a heads up: you do not run a proper stable release but a release candidate. (Or even a nightly build from sometime between the rc1 release till today. The version number system used is a bit confusing.)

I cleared this up in the title and also moved your post over to the correct category.


Just tested it in todays nightly and it works as expected for me. Route is ended if kicad is able to place a trace end at the center of a pad.

Could you post a screenshot of the area where you have trouble? Maybe one where you forced kicad to end routing after placing the last trace point? (The ESC key ends routing of the current trace)


#4

Hi Eelik and Rene and thanks you very much for your help !

Eelik found the problem ! Enabling again “Magnetic pads” solve this issue. I don’t know why this setting was disabled while upgrading to Kicad 5. To be sure not getting more problems I erased all my .config/Kicad folder to reinitialize all my settings.

So I don’t know if this is a bug or not :

-> Even if you disable “Magnetic pads”, when you click on the Pad edge the track start from the pad center.

-> But with “Magnetic pads” disabled, the track never want to end.

Thank you again !

Baptiste.


#5

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.