Using Notepad to "Show" Symbol Properties>Visability. Also need to "reset" Postion X & Y


I’m trying to “Show” a Field stored in the Symbol Properties on my Schematic in Eeschema. I could click into each component’s properties, select the field, and choose Visability “Show” but I figured editing the text in notepad might be easier.

The problem is that each component’s “position” is all over the place - not aligned anywhere near where the actual component is located. This would be a huge chore to clean up. So I’m trying to set the position to null. Here is what a line looks like in notepad.

F 4 "CAP CERM 10uF 16V 20% X7R ROHS" H 0 0 50 0000 C CNN "Description"

F 4 "CAP CERM 10uF 16V 20% X7R ROHS" H 0 0 50 0001 C CNN "Description"

The numerical digits after the “H” are the position. For example “H 5815 2240” is the position. If I just do a find and replace on the “0001” to “0000” then it will “show” the field. But by leaving the position field as default “0 0” the location is messed up when opening Eeschema. The “Description” is out in left field somewhere.

What can I replace “H 0 0” with to “null” it out and force the software to position everything near the component? I tried “H . .”. I tried just blank. But it actually breaks the entire schematic when I do that.

Thanks for your advice!

KiCad typically autoplaces fields (can be turned of in the preferences)
I guess you editing the file with a text editor does something that screws up that algorithm


Is there a way to “show all” for a component’s field?

In fact, before I even started messing with the notepad edits, it seemed as if the fields were getting inserted in a strange location. Each “description” has a predefined “position”, I never set… It’s somewhat odd to begin with that the position is pre-defined in the edit properties box too. Any advice?


Is that because of the "Symbol Field Automatic Placement’ setting in the eeschema preferences?

What probably happened is when I edited the “description” field in the Tools>Edit Symbol Fields area with the “automatic placement” option turned on, it probably populated the field locations for each of the components as well… By mistake maybe?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.