Using Kicad 5.0.2 pcbs with eyrie (online viewer)


#1

Hey guys,

I have a 4 layer board that I made in the latest version of KiCAD, and I want to upload it to eyrie.io which is an online viewer. When I try to do this, it gives me an error:
SExp unmarshal error at line: 3 column: 3: Missing required field for tag: links [0xc42c5741c0]

I tried uploading a board which I made in 4.0.7 and that worked fine. I think the problem lies in the general section of the pcb file. Here is the section in question from the board that worked:
(general
(links 395)
(no_connects 7)
(area 29.213095 7.038999 195.224685 198.775)
(thickness 1.6)
(drawings 138)
(tracks 1027)
(zones 0)
(modules 151)
(nets 122)
)

And the one that didn’t:
(general
(thickness 1.6)
(drawings 88)
(tracks 741)
(zones 0)
(modules 73)
(nets 109)
)

Does any one know if/how I can modify the problematic board (maybe adding the links tag or something) so that I can upload it to the site? I did contact the eyrie developers but have not heard anything from them.

Thanks


#2

I would suggest you make a report over at that project as i doubt the guys working on that visit this forum.


#3

I don’t expect them to see this, I was just wondering if anyone familiar with the KiCAD pcb file format could help me downgrade (I guess) my board from 5.0.2 to 4.0.7 so that their viewer won’t throw an error. I think it involves adding the links tag and whatever else is missing. Thanks for the response though.


#4

I don’t know all the pcb format quirks, I guess your second board is not finished.

In my v5 and v5.1 finished boards the lines (links) and (no_connecst) are not present.

I have opened a v5 board with the v4.0.7.
Change the first line by a v4.0.7 first line from another project. Just to cheat the parser telling it the file is v4.

This trick will not work if the v5 board has elements not supported by v4.
For example rounded rectangle pads are supported by v5 but aren’t by v4.

When opening the v5 board with pcbnew v4.0.7, the parser will tell you in which line of the file there is the first error encountered. Open the kicad_pcb file with a text editor I try to guess what the error is and see if it can be avoided with some manual editing.

Good luck!


#5

I actually did manage to fix it manually. I filled in the no_connects tag by counting the number of occurrences of “NoConn” in the schematic file and filled in links by counting the number of occurrences of “Connection” in the schematic file. For area I just chose two coordinates of a bounding box.

Thank you for your help