USB Type C Routing Beginner Problem (SOLVED)

I have only been using KiCad (v5.1.9-1 ) for a few days.
I am trying to design a small USB Type C USB 2.0 adapter board that only has a resistor to ground on pins CC1 and CC2 and outputs the other signals on a pin header. I use the socket TYPE-C-31-M-12:
In the schematic I added the single components and also added the footprints.
However, when I switch to the PcbNew and click “Update PCB from schematic”, the components are shown but all the connections are not shown. I also can’t manage to manually connect a GND pin of the USB socket to the GND pin of the pin header.
Can anyone give me a hint what I have to do or what I am doing wrong?
Unfortunately I can’t seem to upload any files yet, otherwise I would have attached my project.

Try to upload now. Your version is a little outdated and it seems there was a little discussion on this lately but I thought it might be for the upcoming V6 release.

While we normally recommend the current stable release several developers have suggested that V6RC1 is probably more stable than V5 releases because that is where the effort is heavily focused and bugs get squashed pretty quick versus waiting for a new V5 release. So, if you are new, you might consider staring with V6RC1.

Hi hermit,

thanks for the suggestion.
I think I am blind. Where can I find the download for version 6 RC1?
Unfortunately I still can’t upload attachments: “Sorry, new users can not upload attachments.”

If you are on windows and go to nightly development builds:

I wonder if it is a cookie problem. You’ve been ‘leveled up’ to basic user. That should be good enough.

I have now installed the latest version (6.0.0-rc1-160-g99ec2b1801), but unfortunately the problem persists. As if the footprints were not connected to the pins of the schematic.
Now the upload was successful, maybe really a cookie/cache problem.
USBC.7z (480.3 KB)

Typical source of such questions here is that pins are not connected at schematic. Little square or circle at wire end says it is not connected. Unfortunately I can’t check it myself - I don’t have V6 as it needs Win10 and I have Win7.

Maybe you need to post a zip of your project folder. If there is more there than you want to disclose, then copy the files and chop the copies down to something just enough to show the problem. The source of the problem will probably be obvious to me and/or some of the many users of 6.0.

Woops I see that you are as yet unable to do that. Are you permitted to send them via private message? Click on my icon (and maybe a few others) and select the envelope image.

Hi BobZ,

in my last post I attached a USBC.7z. Don’t you see it?

Isn’t that exactly what he did in the post two posts before yours?

If you’re unable to read 7zip, here it is as a regular zip. (579.0 KB)

1 Like

Hi Piotr,

can’t you open the project I uploaded with your KiCad v5? I can also save it again under v5 on my laptop, would that help you?

It looks like your problem is a mismatch in the pin numbering between your symbol and your footprint. Your USB-C symbol uses purely numeric pin numbering (1-13), while your USB-C footprint uses alphanumeric pin numbering (such as B5, A9, etc.).

You can see the problem when you try to update the PCB from the schematic:


Hi ppelleti,

now that you say it, it’s pretty obvious to me, too. Thank you for the hint. I have now used a different symbol in the Schematic Editor that also uses the alphanumeric notation. In the PCB Editor I can now route everything as expected. Thanks!

P.S.: Can I mark my question as solved somewhere?

You have the ability to edit the title of the thread. I’ll do it this time.

Glad you found what you need and welcome. :smiley:

I even didn’t tried as you said you moved to V6. I don’t need to see it.
You can just check if wires at schematic have little circles at their ends.
It is only the information that it happens here that people ask the question like you while they just have not connections at schematic. The typical reason is that they change grid while editing schematic.

After writing that I see your problem is already solved.

I was able to successfully open it with 5.1.12.

That was not the problem. The problem was that the symbol used different pin numbering than the footprint.

I noticed it and written:

Sorry folks that I did not notice the zip earlier. Then I was outdoors for a few hours. Glad that the problem is solved.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.