Upgrading to V6

I installed V6 in a different directory and did a PCB with it. All went well at first. I like the changes and improvements.

Then I attempted to make some changes. Huge mess! Thanks to paulvdh for his assistance. It took a while, but now I am back to my initial problem.

Much is written in the FAQs about multiple versions installed on the same computer. Initially I ignored it, as my first foray into V6 went well. The board is built and working. But when I started to make changes, I noticed that some of my schematic files appeared to have V5 icons despite their being V6. Attempting to open them resulted in an error message “this doesn’t appear to be a eeschema file”. Attempting to open a similar PCB file resulted in “this file was created in a later version” etc. Opening the various project files showed they were trying to open in 5.12 instead of V6.

Then I received a set of schematics from another member of my team that were done in V6, but all the icons were V5 and wouldn’t open, with the same above error messages.

I then installed V6 on my laptop, which didn’t have KiCad on it. When opening his files, they were all correct and opened properly.

Now I had a clue. I returned to this Forum and began reading about multiple versions on Windows. I admit to not understanding the concept of environment variables. The more I read the more confused I get. I’ve never experienced this kind of trouble upgrading software.

My choice would be to just get rid of V5, but I do work for several others, and getting them to upgrade is like herding cats. There are a few boards done in V5 that I will have to deal with in the future. Is it possible to upgrade the existing V5 boards and schematics to V6? Or must I have both versions installed as per the details provided in the FAQs?

With V6, what files does another team member need to send me so I may begin the PCB process?

Thanks for all your help with these issues.

bdh

I am not sure if this is your whole problem or just part of it, but on Windows, you can choose what program to open files with when you double-click them. To change this association, you right-click and choose Open With. It sounds like your computer is defaulting to opening KiCad files in V5, which will give the error messages you describe.

You can also open KiCad 6 first and then open the project from the KiCad File menu, instead of double-clicking files.

That sounded simple enough, but when I right click on the file I just get Open, not Open With.

bdh

image

1 Like

OK - I was trying to open it from within his zip file and didn’t get the “open with” selection. I moved the file to the desktop and then tried it; ‘open with’ worked. Thanks for that suggestion.

bdh

2 Likes