Upgrading kifield


#1

I’m afraid this is a very basic question, but I don’t know much about python.

I have kifield 0.1.7 installed on my Mac, but I would like to upgrade to kifield 0.1.8, because it has the fix to bug 32.

I tried using easy_install to upgrade kifield, but it seems to want to stick with version 0.1.7:

whiteandnerdy:~ ppelleti$ sudo easy_install -U kifield
Password:
Searching for kifield
Reading http://pypi.python.org/simple/kifield/
Couldn't retrieve index page for 'kifield'
Scanning index of all packages (this may take a while)
Reading http://pypi.python.org/simple/
Best match: kifield 0.1.7
Processing kifield-0.1.7-py2.7.egg
kifield 0.1.7 is already the active version in easy-install.pth
Installing kifield script to /usr/local/bin

Using /Library/Python/2.7/site-packages/kifield-0.1.7-py2.7.egg
Processing dependencies for kifield
Finished processing dependencies for kifield

On the kifield github page, there’s a badge that says “pypi v0.1.8”, so I’m assuming that version 0.1.8 has been published.

Any ideas why easy_install isn’t seeing it? Is there a “manual” way of installing kifield?

I’m running Mac OS X 10.9.5:

whiteandnerdy:~ ppelleti$ uname -a
Darwin whiteandnerdy.lan 13.4.0 Darwin Kernel Version 13.4.0: Mon Jan 11 18:17:34 PST 2016; root:xnu-2422.115.15~1/RELEASE_X86_64 x86_64
whiteandnerdy:~ ppelleti$ python --version
Python 2.7.5

#2

Either easy_install or pip should work for you. I don’t use Mac or OSX, so I don’t know if those are causing an issue although I will say a disproportionate number of problem reports I get involve OSX.


#3

I tried pip and it simply left kifield at 0.1.7, as well.

However, I also have python3 installed via Homebrew, so I tried pip3, and that upgraded my kifield to 0.1.8 successfully.

Not sure why python2 didn’t want to upgrade my kifield, though.


#4

I think you need to add a --upgrade switch.

  -U, --upgrade               Upgrade all specified packages to the newest
                              available version. This process is recursive
                              regardless of whether a dependency is already
                              satisfied.



#5

But -U is supposed to be synonymous with --upgrade.