Upgraded Kicad 5.1.2-2 to 5.1.10-1, got empty fields

Hi all,

To be compatible with one plugin in PCB editor, I had to downgrade my version in Kicad. 5.1.2-2 to 5.1.10-1.

But now if I go to field symbol in eechema, “Value, footprint” field are empty, but not on my schematic.
Is there a way to correct this problem ?


That’s an upgrade. Version numbers are multipart of form major.minor.release-extra. Compare the two:

5 = 5
1 = 1
2 < 10

Comparison stops here. So 5.1.10 is newer than 5.1.2.

5.1.2-2 is over two years old.
I changed the thread title to be more accurate
Did you actually mean downgrade from 5.1.10 to 5.1.2?

Haha, my bad effectively, this is an upgrade !

Thanks ! Haha, my bad effectively, this is an upgrade !

I hope you still have copies of the old project.

This reeks of a bug in Eeschema. I’ve seen a few other threads recently, but in those threads fields were duplictated and appeared twice in the schematic.

It may be that the bug is triggered by a non-english GUI settings.
Can you try to:

  1. Set KiCad’s GUI to English.
  2. Open a copy of the old project again in a newer KiCad.
  3. Look at the results.

Another way to try to resolve this is with a text file comparison program, such as for example meldmerge

That would not surprise me. I just had a bug happen in Eeschema, lost all (wow, all 3 of them) symbols after using the library editor… and no, I did not change 2 of the symbols that somehow got lost. Unable to duplicate the bug.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.