Updating schematic after running renumbering

When using the Geographical Re-annotate, everything works on the Layout side, except when I want to update the schematic side I do not get the pop-up window to instruct Kicad to carry on updating the schematic.
Anyone else had the problem or what am I doing wrong. I have to kill the current session as I could not close the program normally.

Application: KiCad

Version: 6.0.7-f9a2dced07~116~ubuntu20.04.1, release build

Libraries:
wxWidgets 3.0.4
libcurl/7.68.0 OpenSSL/1.1.1f zlib/1.2.11 brotli/1.0.7 libidn2/2.2.0 libpsl/0.21.0 (+libidn2/2.2.0) libssh/0.9.3/openssl/zlib nghttp2/1.40.0 librtmp/2.3

Platform: Linux 5.4.0-124-generic x86_64, 64 bit, Little endian, wxGTK, xfce, x11

Build Info:
Date: Jul 26 2022 19:32:41
wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 3.24
Boost: 1.71.0
OCC: 7.5.2
Curl: 7.84.0
ngspice: 36
Compiler: GCC 9.4.0 with C++ ABI 1013

Build settings:
KICAD_USE_OCC=ON
KICAD_SPICE=ON

it’s a bug in 6.0.7 that the update schematic from PCB window doesn’t come up. It’s been fixed and will be in the upcoming 6.0.8.

1 Like

… probably at the end of this month. Meanwhile, if the function is important, it’s possible to use a “testing build” for Windows, and it seems to exist for Ubuntu, too: https://launchpad.net/~kicad/+archive/ubuntu/kicad-6.0-nightly (which may override the stable 6.0 release). It has the latest stable version + bugfixes which will be part of the next stable version. Sometimes a bugfix causes a new bug, so it’s recommended only if you need a certain bugfix or want to help with testing.