Updating PCB with Schematic leads to error (using Database Library)


I’ve a got a little problem with updating a PCB with a schematic, which contains a symbol from a database. The database seems to be hooked up correctly, as I can find the component (so far only the RP2040) in the component explorer.

The schematic is as following and is very simple (just for testing purposes):

Also important to note is, that the component has both a symbol and a footprint. So in some way, it seems to be able find everything required.

The symbol’s properties are completely empty, as the information is inserted via the database:

I took the database template from a course from my university and has one entry:

Trying to update the PCB leads to following error:

Did someone else have similar experiences and figured out a solution?

Also if anything is missing, ask and I’ll try to provide the missing stuff.

To help you with this, some further info can be useful:

  • Your kicad_dbl file
  • kicad version info (under help menu)

Thanks for your reply. I’ve attached both .db & .kicad_dbl.

libKiCad.db (84 KB)

libKiCad.kicad_dbl (36.0 KB)

And here’s the kicad info

Application: KiCad x64 on x64

Version: 8.0.0, release build

	wxWidgets 3.2.4
	FreeType 2.12.1
	HarfBuzz 8.3.0
	FontConfig 2.14.2
	libcurl/8.5.0-DEV Schannel zlib/1.3

Platform: Windows 11 (Erzeugungsversion 22621), 64-bit Edition, 64 bit, Little endian, wxMSW

Build Info:
	Date: Feb 23 2024 02:24:15
	wxWidgets: 3.2.4 (wchar_t,wx containers)
	Boost: 1.83.0
	OCC: 7.7.1
	Curl: 8.5.0-DEV
	ngspice: 42
	Compiler: Visual C++ 1936 without C++ ABI

Build settings:

This is the ODBC Data Source Management entry

…i cannot spot anything obvious from your info.
Have you tried to pass your .kicad_dbl file to an online validator?
In the big thread about database library, craftyjohn was suggesting some link about that.

If nothing comes out of that, i’d just try to simplify your configuration with just 1 family (ic) and a few fields (value, category) and see what happens…

Thanks, yeah that would make more sense. I found some funny behaviour. When I restart my laptop (not just close and reopen kicad) the updating works. I’ll look into the mentioned thread.

Thanks again!

here. sit down, and grab a cup of coffee :slight_smile:

Good afternoon, did Wang manage to find the reason? I have exactly the same situation, the footprint is transmitted only once after a reboot, then the same error pops up as yours