Updating footprints v7.0.10 -- Quirky behaviour

I have just noticed a quirk / bug in v7.0.10:

If I edit a library footprint (not the copy residing within the Project), and then return to the PCB or to the schematic and open the symbol or footprint editor and attempt to update the footprint associated with the symbol, I have been getting the message that the footprint has not been changed (and therefore, no update occurs).

I must instead select ‘Change Footprint’, and then choose the same footprint from the library, in order to force the update & so reflect the changes I made to the library version.

This is the first time I have seen this behaviour (I have only been using 7.0.10 for a few days), so I am not sure that it isn’t some quirk that will disappear when I shut down and restart the computer. It does NOT seem to make any difference if I simply close the KiCad editors and shut down KiCad altogether.

This worked, as expected, for me.

The action “update” requires a single left click.

Thanks for confirming that it worked for you, JMK.

I had shut down completely overnight and restarted, so I checked again and I had the same quirky experience.

Then, I noticed that the update options were not “the full-meal deal”. I had only installed 7.0.10 a few days ago and I had not altered any of these, and was not expecting that not “all” of the footprint changes would be updated by default.

As it turned out, I had only made a change to text on the silkscreen layer (specifically, I added a dot to indicate #1 pin of a SMD device, so that I could orient the 3d model correctly)

So quirky mystery solved.
Thanks again for your help

2 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.