Updating already installed plugins using Content Manager?

See the end for my version information.

I was looking through the Plugin and Content Manager and noticed that some of my installed plugins are out of date. But I can’t find a simple way of upgrading an already installed plugin.

Here is a sample, apparently I’m two versions behind on Archive 3D Models:


I have version 1.0.1 installed, but the latest stable version is 1.0.3. How do I upgrade? Download the version and use “Install from File…”? Uninstall and then reinstall?

Is a direct upgrade feature planned for future release?

Application: KiCad (64-bit)

Version: (6.0.4), release build

Libraries:
wxWidgets 3.1.5
libcurl/7.78.0-DEV Schannel zlib/1.2.11

Platform: Windows 10 (build 19042), 64-bit edition, 64 bit, Little endian, wxMSW

Build Info:
Date: Mar 18 2022 03:04:44
wxWidgets: 3.1.5 (wchar_t,wx containers)
Boost: 1.76.0
OCC: 7.6.0
Curl: 7.78.0-DEV
ngspice: 36
Compiler: Visual C++ 1928 without C++ ABI

Build settings:
KICAD_USE_OCC=ON
KICAD_SPICE=ON

Hmm, this seems like a bug. I would think the “install” button should not be disabled if you have the newer version selected in the table.

Uninstall and reinstall should work as a workaround.

Yeah, uninstall and reinstall did work, but is quite klunky. I submitted a bug report here:

Yes, smooth update experience for PCM is on my radar.

Not a bug, there is no internal “update available” state yet. Install should be preceded with uninstall (possibly partial to keep configs for example) and that is not implemented so for now the manual uninstall/install is the only approach.

1 Like

First I’d like to thank you for setting up and maintaining the PCM and corresponding infrastructure.

While you’re looking into PCM, it seems that kicad_version is not a hard requirement but more of a suggestion. I’ve had users install my plugin (SaveRestoreLayout), which should be limited for use with 6.0.3+, on 6.0.2

The same goes for kicad_version_max. I’ve had users of 6.99 install my plugin (PlaceFootprints) which should be limited to 6.1 by kicad_version_max.

That’s a bug. For some reason only major.minor is parsed, not the patch version.

You missed setting kicad_version_max on v1.0.0
image