Update Kicad 5.1.4 to 5.1.5 or newer version on Raspberry Pi 4 running Raspbian?

Greetings Everyone!
It looks like i need update my Kicad 5.1.4 for a newer version on my Raspberry Pi 4 which is running Raspbian.
I tried the sudo-apt get update,full-upgrade etc. and reinstall the kicad but it does not work.
Is it possible to update it?
Any little help would be appreciated!
Thank you for your time!
Best regards,
Daniel

What repos do you have in your apt config?

If you have the standard Raspi Debian repo, a look through the repo shows that the latest build is 5.1.4:

https://archive.raspberrypi.org/debian/pool/main/k/kicad/

So you probably have to get them from the Debian Buster backports repo with a line like this:

deb https://deb.debian.org/debian buster-backports main

in /etc/apt/sources.list.d/buster-bpo

Then apt update, and apt search kicad should find the 5.1.6 version.

1 Like

Hello @kenyapcomau
Thank you for your fast answer!
I have the standart Raspbian repo.
I only have raspi.list in /etc/apt/sources.list.d .
Can i add this line to that file too?
If i dont have buster-bpo can i create one, or it does not matter?
Best regards,
Daniel

It doesn’t matter which file you put the line in, but since it’s a unrelated repo, creating a new file (of any name) makes it clearer.

So i add that line.
Now i added it to the raspi.list.
Then i apt update and search for kicad but it still show the 5.1.4
It seems it does not update anything because it is not signed or something like that?
Can i change the default settings to let unsigned repos update?
I added images about the result.


[UPDATE]
I searched on the internet to solve the issue and i added this line to the /etc/apt/sources.list.d
deb [allow-insecure=yes allow-downgrade-to-insecure=yes] https://deb.debian.org/debian buster-backports main
Then i ran apt update but didn’t work out, and the terminal sent the following message:

Hit:1 http://archive.raspberrypi.org/debian buster InRelease
Get:2 https://deb.debian.org/debian buster-backports InRelease [46.7 kB]
Ign:2 https://deb.debian.org/debian buster-backports InRelease
Get:3 http://raspbian.raspberrypi.org/raspbian buster InRelease [15.0 kB]
Get:4 http://raspbian.raspberrypi.org/raspbian buster/main armhf Packages [13.0 MB]
Fetched 13.0 MB in 4min 6s (53.0 kB/s)
Reading package lists… Done
Building dependency tree
Reading state information… Done
2 packages can be upgraded. Run ‘apt list --upgradable’ to see them.
W: GPG error: https://deb.debian.org/debian buster-backports InRelease: The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY 04EE7237B7D453EC NO_PUBKEY 648ACFD622F3D138
W: The repository ‘https://deb.debian.org/debian buster-backports InRelease’ is not signed.
N: Data from such a repository can’t be authenticated and is therefore potentially dangerous to use.

You should import the Debian archive keyring first. Download the package from:

https://packages.debian.org/buster/all/debian-archive-keyring/download

then install it manually with

dpkg -i debian-archive-keyring_2019.1_all.deb

Then you will be able to apt update without having to bypass security warnings.

1 Like

Thank you very much!
Now i can apt update without error message, however i still have the problem if i run apt seach kicad then it still shows me the 5.1.4 version :frowning: .

After apt update:

Hit:1 https://deb.debian.org/debian buster-backports InRelease
Hit:2 http://raspbian.raspberrypi.org/raspbian buster InRelease
Hit:3 http://archive.raspberrypi.org/debian buster InRelease
Reading package lists… Done
Building dependency tree
Reading state information… Done
2 packages can be upgraded. Run ‘apt list --upgradable’ to see them.

After apt search kicad:

Sorting… Done
Full Text Search… Done
horizon-eda/stable 0.20181108-1+b1 armhf
EDA layout and schematic application

kicad/testing,now 5.1.4+dfsg1-1~bpo10+1 armhf [installed]
Electronic schematic and PCB design software

kicad-common/testing 5.1.4+dfsg1-1~bpo10+1 all
Old common files used by kicad - Transitional Package

kicad-dbgsym/testing 5.1.4+dfsg1-1~bpo10+1 armhf
debug symbols for kicad

kicad-demos/testing,now 5.1.4+dfsg1-1~bpo10+1 all [installed,automatic]
Demo projects for kicad

kicad-doc-ca/testing 5.1.4+dfsg1-1~bpo10+1 all
Kicad help files (Catalan)

kicad-doc-de/testing 5.1.4+dfsg1-1~bpo10+1 all
Kicad help files (German)

kicad-doc-en/testing 5.1.4+dfsg1-1~bpo10+1 all
Kicad help files (English)

kicad-doc-es/testing 5.1.4+dfsg1-1~bpo10+1 all
Kicad help files (Spanish)

kicad-doc-fr/testing 5.1.4+dfsg1-1~bpo10+1 all
Kicad help files (French)

kicad-doc-id/testing 5.1.4+dfsg1-1~bpo10+1 all
Kicad help files (Indonesian)

kicad-doc-it/testing 5.1.4+dfsg1-1~bpo10+1 all
Kicad help files (Italian)

kicad-doc-ja/testing 5.1.4+dfsg1-1~bpo10+1 all
Kicad help files (Japanese)

kicad-doc-nl/stable 5.0.2+dfsg1-1 all
Kicad help files (Dutch)

kicad-doc-pl/testing 5.1.4+dfsg1-1~bpo10+1 all
Kicad help files (Polish)

kicad-doc-ru/testing 5.1.4+dfsg1-1~bpo10+1 all
Kicad help files (Russian)

kicad-doc-zh/testing 5.1.4+dfsg1-1~bpo10+1 all
Kicad help files (Chinese)

kicad-footprints/testing,now 5.1.3-1~bpo10+1 all [installed,automatic]
Footprint symbols for KiCad’s Pcbnew

kicad-libraries/testing,now 5.1.4+dfsg1-1~bpo10+1 all [installed,automatic]
Virtual package providing common used libraries by kicad

kicad-packages3d/testing 5.1.3-1~bpo10+1 all
3D models for 3D viewer in KiCad’s Pcbnew and Footprint Editor

kicad-symbols/testing,now 5.1.3-1~bpo10+1 all [installed,automatic]
Schematic symbols for KiCad’s Eeschema

kicad-templates/testing,now 5.1.3-1~bpo10+1 all [installed,automatic]
Project templates for KiCad

pcb-rnd/stable 2.1.1-1 armhf
Modular Printed Circuit Board layout tool

Should i upgrade as well?
Should i remove first kicad then update and then install?

Hmm, I am unable to help much here as Debian is only on my old RPi 1 and that’s armhf. The 5.1.6 package is definitely in buster-backports, see:

https://packages.debian.org/buster-backports/kicad

Edit: actually I think it’s more likely it needs dependencies from the main buster repo so you need another line:

deb https://deb.debian.org/debian buster main

You should be aware that adding the buster repos can cause Raspberry Pi OS (the new name of Raspbian) to think some other packages need updating. After you have acquired KiCad 5.1.6 you might want to disable the buster repo by commenting out the lines. Adding another repo, albeit a closely related one, is a bit of a calculated risk.

1 Like

You already helped so much and thank you for that!
Sadly I added the new line, but i just got new upgrades, i tried to reinstall kicad but did not work out as well. Tried to full-upgrade but it doesn’t semm too work as well.
I have noticed i have a sources.list file outside the sourdes.list.d and i got lines in that too.
(Sorry, but i’m beginner in the linux OS and i dont know much about it.)
So i got these lines:

deb http://raspbian.raspberrypi.org/raspbian/ buster main contrib non-free rpi
#Uncomment line below then ‘apt-get update’ to enable ‘apt-get source’
#deb-src http://raspbian.raspberrypi.org/raspbian/ buster main contrib non-free rpi
#deb http://deb.debian.org/debian/ buster main
#deb-src http://archive.raspbian.org/raspbian buster main contrib non-free
#deb [trusted=yes] http://deb.debian.org/debian/ buster-backport main contrib non-free

Almost all of them were commented out. Can’t it be a problem or something like that?
So i got these 2 file one is inside the sources.list.d(raspi.list) and one is outside of it.(sources.list)

You hardly ever need deb-src lines so that line can be ignored. You might try adding contrib to the end of your existing buster lines in case 5.1.6 was put in that category. I can’t find an easy way to find out which category a particular Debian package was put into. Definitely not non-free though.

Maybe i solved the problem i dont know surely.
I just browsed on the link you sent to me.
https://packages.debian.org/buster-backports/kicad
And then i scrolled below and in the download kicad i saw an amrhf and then i get to this page:

https://packages.debian.org/buster-backports/armhf/kicad/download

I downloaded one and installed it, then it seems now i have kicad 5.1.6

That’s one way of solving it. I would have thought there might be some updated dependencies from 5.1.4 but it seems not. You might want to upgrade all the other 5.1.4 packages you had: doc, symbols, etc.

I thought you would be running arm64, but then you reminded me that Raspberry Pi OS is only available in 32-bit flavour. The apt sources lines handle this automatically, the package maintenance utilities take into account the architecture of the machine it’s running on.

1 Like

Thank you very much @kenyapcomau !
Without your help i would still struggle with this problem!
Best regards,
Daniel

:+1: No worries. I wish you much enjoyment with KiCad.

Just for completeness, Raspian is not Debian! So Debian can’t be responsible about what KiCad version in particular is available in Raspian. Raspian is also not pulling in automatically (to my knowledge) Debian packages (like Ubuntu is doing in their development release tree). So using packages from Debian within Raspian might work but it’s not guarantied it will. If you have a lot of time you can rebuild KiCad from source on your Raspi device by your own of course.

As I wrote it’s a calculated risk. Most derivatives of Debian can use Debian repos, and some even explicitly use Debian as the base repo, e.g. AntiX, but you have to be prepared for what might happen. That’s why for the odd package our two I recommend getting just what you need and then disabling the Debian repo afterwards otherwise you end up upgrading more of your system than intended…

Ubuntu and Debian parted ways long ago and the connection is via source DEBs.