Update footprint in the urrent pcb layout

i have created the schematic and assigned the through hole resistor footprint to resistor.

Now i want to change the footprint from through hole to SMT.

i have generated and loaded again. but it is not getting updated in layout (.pcb) file.

i don’t want to restart the work again because already spent few hours on them.

how can i update the resistor footprint from through hole to SMT?

There are more ways to do it, but I tell you the 2 easier ones:

1.In eeschema open cvpcb “Assign PCB footprints to schematic symbols” and assign the SMD footprint to the resistor you want. In v5.1 is the 6th icon of the top toolbar from the right.
2. In eeschema, edit the resistor symbol (select the resistor en hit “e”) and assign the resistor SMD footprint on the Footprint field.

After having done 1 or 2, Tools->Update PCB from Schematic…

It can also be done from the layout editor but I think it is too complicated for now.

Since KiCad V5 (maybe earlier?) there is also:

Eeschema / Tools / Edit Symbol Fields.

This gives a very quick and easy overview of all attributes of all schematic symbols, including the Footprint.

Because you can group components based on their attributes it is very easy to copy one value field to a lot of others.
The easiest way to do it is to first assign one footprint manually. Hover over a symbol and either use “e” to edit as Pedro suggests, or use “f” to directly edit the Footprint field of a symbol.

If you have already changed the footprint assignment in the schematic and are having trouble getting the change to be reflected on the PCB, try selecting the Update footprints option when updating the PCB from Schematic. See here:
If you are using the depreciated workflow of netlists (depreciated that is within the scope of a fully KiCad design) that dialog box has an identically named option.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.