Unhide/view invisible text in PCBnew

v5_0

#1

Hello,
I have some invisible text on silk and fab layers that cluttered the PCB and assembly drawings. But now I want to unhide them or make them visible again. I cannot reach them with my mouse pointer, they are grey and transparent and cannot be clicked. I have tried hovering my mouse pointer over the text and pressing ‘E’ on the keyboard.

Kicad 5.0.2


#2

Assumptions: The text is part of the footprint. And 5.0 works the same as 5.1 (Really you should update. Files are fully backwards and forward compatible from 5.0 to 5.1 but the later got many new interface features.)

The right sidebar (Layers Manager) has an item view. In it select “hidden text” to be visible. (It of course only shows the text if the layer it is on is also set to visible)


#3

I am trying to update KiCad it just takes some time because I’m not administrator of this computer.

The option you showed me worked to completely hide the hidden (invisible) text versus having it greyed out. In both cases I cannot edit the text properties to mark it visible again.


#4

Works in 5.1.2 -> seems to have been one of the bugs fixed since your version was released.

Possible workarounds (not tested in 5.0 because i am not going to downgrade to a buggy version.):

  • right click on text to get its context menu -> edit
  • mark text with left click before using shortcut e
  • use the alt key to force getting the disambiguation dialog before any of the above options (including directly using hotkey e).
  • use the properties dialog of the footprint (there should be some way to edit the field properties even in 5.0)
  • use a text editor on the file (I would highly suggest sending a beer to your admin to get your version updated right now instead of going this dangerous route).