Unfound libraries


#1

I am quite new in KiCad and I am having some problems with the libraries that are not found anymore in the computer

Errors were encountered loading footprints:
IO_ERROR: footprint library path ‘/usr/share/kicad/modules//Relays_ThroughHole.pretty’ does not exist
from kicad_plugin.cpp : FootprintEnumerate() : line 1801
IO_ERROR: footprint library path ‘/usr/share/kicad/modules//Resistors_ThroughHole.pretty’ does not exist
from kicad_plugin.cpp : FootprintEnumerate() : line 1801
IO_ERROR: footprint library path ‘/usr/share/kicad/modules//Buttons_Switches_ThroughHole.pretty’ does not exist
from kicad_plugin.cpp : FootprintEnumerate() : line 1801
IO_ERROR: footprint library path ‘/usr/share/kicad/modules//Capacitors_ThroughHole.pretty’ does not exist
from kicad_plugin.cpp : FootprintEnumerate() : line 1801
IO_ERROR: footprint library path ‘/usr/share/kicad/modules//Connect.pretty’ does not exist
from kicad_plugin.cpp : FootprintEnumerate() : line 1801
IO_ERROR: footprint library path ‘/usr/share/kicad/modules//Terminal_Blocks.pretty’ does not exist
from kicad_plugin.cpp : FootprintEnumerate() : line 1801
IO_ERROR: footprint library path ‘/usr/share/kicad/modules//Diodes_ThroughHole.pretty’ does not exist
from kicad_plugin.cpp : FootprintEnumerate() : line 1801
IO_ERROR: footprint library path ‘/usr/share/kicad/modules//Display.pretty’ does not exist
from kicad_plugin.cpp : FootprintEnumerate() : line 1801
IO_ERROR: footprint library path ‘/usr/share/kicad/modules//Sockets_BNC.pretty’ does not exist
from kicad_plugin.cpp : FootprintEnumerate() : line 1801
IO_ERROR: footprint library path ‘/usr/share/kicad/modules//Sockets_Mini-Universal.pretty’ does not exist
from kicad_plugin.cpp : FootprintEnumerate() : line 1801
IO_ERROR: footprint library path ‘/usr/share/kicad/modules//Sockets_WAGO734.pretty’ does not exist
from kicad_plugin.cpp : FootprintEnumerate() : line 1801

The other used libraries are recognized (generally SMD ones).

I already tried download the GitHub repository and add the folder to KiCad.


#2

What operating system? (For linux: distribution and version, for windows and mac: version)
What kicad version?
How did you install kicad? (Especially important for linux users)
Have you changed the fp-lib-table entries? (By hand or via the library wizard)

Without that information we are a bit blind and can only give generalized answers. (That might lead to a more complicated solution for your problem.)

It seems like there are entries in your fp-lib-table that are not found by kicad. (Do not exist in the path it looks for them.)

Solution
Because of the limited amount of information i have here, i can only suggest a “re-installation” of the footprint libs.

I assume you want offline libs. (Online libs should be reserved for advanced users who know what the downsides of online libs are.)
For that simply follow the tutorial by @bobc:


#3

Hi,

I am using KiCad 4.0.7-e1-6374~58 on Ubuntu 16.04.01. It was installed by apt-get with all suggested packages.

And when I drew the schematic, I change the footprint associated to each symbol in my schematic starting by wizard and after copying and past the equal string names.

Some footprint name/libraries that are not recognized in the “Run CvPcb to associate components and footprints” are showed when I look in the “Component Properties” using “Assign Footprint”, e. g. “Diodes_ThroughHole.pretty” that I used the “Diodes_SMD:D_SOD-123” footprint.

I used now your suggestion, purge (remove) all the software packages and re-install, but nothing different happens.


#4

Did you really follow all steps of the tutorial i linked or did you just use apt to re-install kicad?
Kicad has it’s own tool for managing footprint libs. Library wizard and library manager accessible via the preferences menu entry of pcb_new.

This is a different problem (I think)

If the lib is in the leftmost column, it does exist. The rightmost column shows filter results.
Check your filter settings within cvpcb
Especially if you do not see the expected footprint even thought the lib you think it is in is in the left colum.


#5

Even if KiCad are released as stable, the libraries become unstable when 4.0 branch are released. This mean:

  1. If you really see your future with KiCad, start to make your own libraries. Both one: schematics and footprints. The official ones changes every minor release and even your old, closed project need to be updated from time to time. With your own libraries you decide about the content of libraries, and will be more easier to you to track these changes and influences to your projects.
  2. If you still want to use stock KiCad libraries, everytime you install new release search for .kicad folder in your home dir and (re)move old fp-lib-table file, then recreate this file with Footprint Libraries Wizard (from CvPcb or Pcbnew). This way you will always have the current footprint libraries in your configuration. The schematic libraries are different story, but -cache.lib of each project is your friend, so don’t remove it.

#6

Understood keruseykaryu, but is not this the problem (I think).


#7

The problem really is:

  1. I have added the footprint of the current internal libraries of KiCad (first figure);
  2. When I check by CvPcb or create the net list some libraries are not recognized (second figure);
  3. I try create net list and this problem if the libraries affect it.

In this project, for example, it is recognized the SMD resistors and capactors libraries but not the SMD diodes and THT resistors. Dispise this, these libraries appear when I try to “Assign Footprint”.


#8

The libraries are recognized, but you have “filter by keywords” selected. Unclick and selections will appear.


#9

Thank bobc
Really, this was a primary error mine and your tip fix my visualization (of some components) in the CvPcb.


#10

Fixed now.
Thanks guys.

The problem was really two configurations:

  1. If the new version of libraries “_ThroughHole” was replace to “_THT”. I changed manually in the KiCad configurations;
  2. The PATH was “/usr/share/kicad/modules/” and each library was linked as “${KISYSMOD}/name.pretty”, wich generate a extra “/”. I changed the path to “/usr/share/kicad/modules” and now works fine.