Unexplained ratsnest line / copper dot invisible in editor - solved

Hi everyone, I am new to this forum so apologies if this is posted to the wrong place or in the wrong way.

I have a random ratsnest line that can’t understand the cause of. One of the endpoints of the ratline is the Mvdd net (highlighted), and the other endpoint seems to go to nothing in the editor, but in the 3D rendering there is a copper “dot” (zero length trace?) rendered.

Would be grateful if someone could shed light on this. TIA

Version info: KiCad 5.1.0-1 Windows 8, build 9200, 64bit

Here is the corresponding 3D rendering. Note the dot at the other endpoint of the mystery ratsnest line, next to the connector south of F92
kicad-screencap-20200218-2

Well for starters, upgrade.
Is there anything on the bottom layer? There is an unconnected node somewherr

@Naib - bottom layer is solid GND all around there (I put it in wireframe view for the screenshot).

I went through all the nets listed in “Inspect->List Nets”, and there is nothing shown on either of the 2 copper layers at the right endpoint of the line …

Rebuild zones and see if it’s still there

Version 5.1.0 is old, you should update to 5.1.9. It’s very possible that not showing zero length segments in the layout is a bug which has been fixed.

You can try to hunt it down with a text editor. Try to locate the exact coordinates of the ratsnest line end and search for it in the text editor.

3 Likes

Backup your work and upgrade, 5.1.0 is two years old and several hundred bugs have been fixed since its release.

Showing tracks and pads in outline allows these little fragments to be seen

@eelik – This worked! I searched for the endpoint coordinate in the text file and found it instantly. Deleted line, problem solved. If anyone cares, it is below. In any case I’m all set. Many thanks!!

(segment (start 47.751998 70.358) (end 47.752 70.358002) (width 0.8) (layer F.Cu) (net 2))

1 Like