"unexplainable" Solder mask clearance in footprint editor


#1

Hi… I have a question: in footprint editor I see a solder mask clearance for footprints, even though I set no mask clearance, neither in PCBnew (dimensions > pads mask clearance), nor in footprint editor itself (edit > edit properties), nor locally on the pads itself (pad properties > local clearance and settings). How come? How can i turn it off?


Default solder mask clearance for footprint editor
#2

I think you stumbled across the Pads Mask Clearance setting from PCBnew making it into the FP editor.

If you set it to 0 in PCBnew it will be zero in FP editor as well.


#3

Hi Joan! I checked before, and in PCBnew > dimensions > pads mask clearance I have everything set to “0”. Nevertheless in Footprint Editor it shows Mask clearance of – I measured it – 0.2mm. I have the version 4.04 stable on Windows 7.


#4

Alright, I think it’s one of Kicads quirks, to show mask clearance even though alle settings are set to 0.00. Since it just shows in Footprint editor, but has no effect on PCBnew, I can live with it.


#5

For OpenGL I can confirm what you found. If you put in anything other than 0.0 it will change to that, but at 0.0 the clearance in the editor/browser goes to 0.2 mm.
The 3D viewer depends on the settings of the tool that started it… it shows what one sees in the respective views.
PCBnew works correctly as you found.

For Legacy mode the solder mask clearance doesn’t show up at all anymore (if it ever has, can’t remember).

Anyhow, feel free to chime in, just filed it:
https://bugs.launchpad.net/kicad/+bug/1637692


#6

Hi Joan! Yes, thanks for confirmation. I think it’s rather a “quirk” than a bug, so I can live with it.