Unexpected behaviour from PCBnew

I have created a new footprint for a horizontal PCB mount 4mm banana socket.

It has two pins which are electrically connected within the socket.

I’ve created the footprint with two PTH pads, both having the same pin number.

I attach the footprint definition.

I plan to connect both pads on both sides of the board, with a heavy trace.

I’m fairly sure I have done similar arrangements previously.

My issue is that if I place a track between the pins on one side of the board, it is placed normally.
However when I place a similar track on the other side of the board, the initially placed track is removed.

Rinse and repeat.

It seems fully reproducible, I’ve set up a pcb with just this footprint and no other tracks and it behaves exactly as in the more complex design I’m working on.

Is there some setting that can switch off this behavior? as parallel tracks on both sides of the board seems a reasonable use case for heavier power uses.

4mm_banana_socket.kicad_mod (4.5 KB)

Cheers Harry

Putting a string of vias along the trace before placing the second track does behave as expected, as I’ve done for power supply tracks before.



It’s not a bug. It’s a feature.

You can turn it off by unchecking the theckbox at: PCB Editor / Route / Interactive Router Settings / General Options / Remove redundant tracks.


Thank you . I hoped there was something like that.

:slight_smile: :slight_smile: :slight_smile:


I’m using 8.0.2.

I assume you mean the preferences dialog

If I’m on the correct dialog, I seem to lack a router option. :frowning:


Ach, wrong dialog.