Unconnected wires in Power


#1

Hi there.
Im pretty new to KiCad, I’ve built 2 or 3 projects and I’ve always had the same issue.
After wiring the whole schematic and running ERC

, I always get 2 or 3 warnings saying “Pin connected to some other but no pin to drive it”. They usually relate to Vcc or GND pins. I visually check where the arrows point to, and the traces seem connected. I even “grab” the connected components and they DO drag the corresponding traces.
Is this happnening to anyone else?
See attached.
Thanks


#2

This is because you have not told Kicad where the power for those nets is coming from, where power enters your circut, add a power flag to VCC and GND (located in the same list as VCC and Ground)


#3

#4

There’s got to be something Im missing. All the VCC’s and GND’s in my schematics are using the same symbol, and in the “Place power port” selection, they already show labeled as “Powe Flags”. I tried removing them and adding them again making sure they are the ones labaled “Power Flag- VCC”, etc and same error
Also, why only those Vcc and Gnd show the error? I have some other Vcc and Gnd with no error

Thanks


#5

Kicad will only ever mark one error on the same net.

And no the vcc and gnd symbols are not power flags. They are “power labels”. (For lack of a better therm.)
The difference is that the vcc and gnd symbols have a single invisible power input pin. Whereas the power flag is a single invisible power output pin.
More details about power input/output see: Electrical type of schematic symbol pins


Also a tip for the future: if you share a screenshot on an international forum change your software to use the english interface (For kicad this is done in the kicad main window -> preferences -> language dialog.)


#6

Ok I’ve found I need to use the specific “diamond” shape icon alone. One linked to Vcc. Another one to GND. That clears all errors. Good.
I had already changed the language in my Kicad to take that screenshot,(check the image above) but for some reason, the specific message errors still showed up in spanish. Maybe I didn’t clear/refresh the ERC errors.

Thanks!


#7

What is surpising me is that a question about it is so often why it is clearly written at page 17 of:
http://docs.kicad-pcb.org/stable/en/getting_started_in_kicad.pdf


#8

That seems to be 16 pages more than what most people read. :wink:


#9

I am uncompatible with current times. I started from reading all documentation. The other subject is how much I remembered :wink:


#10

Sorry guys, you are absolutely right, instead of reading the official documentation, I took another way and watched lots of youtube step by step tutorials before touching the actual program.
Probably none of those tutorials are official and they probably missed the point of the power tags. Either that, or I missed it

Thanks!


#11

On your next screenshot, please try to put all text readable in the schematic without overlap etc. before posting.
This also makes it easier to comprehend where those green arrows actually point to.