Unable to view Gerber files

I am unable to view gerber files. If I open gerber files they appears in the layer manager window, but the viewing screen remains blank. I know that the gerber files are correct (I have send them to a PCB maker and received a good PCB).
The gerber files were created by Kicad.
Not sure how to debug this as there are no error messages.
Kicad version info:
Version: (5.0.1-3-g963ef8bb5), release build
wxWidgets 3.0.4
libcurl/7.54.0 LibreSSL/2.6.4 zlib/1.2.11 nghttp2/1.24.1
Platform: Mac OS X (Darwin 18.2.0 x86_64), 64 bit, Little endian, wxMac
Build Info:
wxWidgets: 3.0.4 (UTF-8,STL containers,compatible with 2.8)
Boost: 1.67.0
OpenCASCADE Community Edition: 6.9.1
Curl: 7.54.0
Compiler: Clang 10.0.0 with C++ ABI 1002

Build settings:

I’m assuming you’re referring to viewing the Gerber Files using GerbView? When you select/open the files and press the “Zoom to Fit” button, the screen is blank? Is there a frame visible? Blue lines showing the 0,0… anything? On the right side the “Visible” layers are all checked? Under Preferences which Toolset are you using?

You have faith, I would have never submitted them without working out the issue.

1 Like

Changing the Preference Toolset did the trick. It was still set at the default setting: “Modern Toolset (Fallback)”.
When I changed it to one of the other settings it worked. Both the “Legacy Toolset” and the “Modern Toolset (accelerated)” are ok.
I can see all gerber files now, except the drill file. Opening a .drl file results in lots of “Unexpected symbol” errors. But maybe that is another problem…
Edit: solved; need to open as “Excellon drill file”.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.