Unable to update kicad with kicad-install.sh

I’m trying to update kicad, but the installer stops at step 5 with this error:

step 5) checking out the documentation from launchpad repo…
bzr: ERROR: Unable to connect to target of bound branch BzrBranch7(file:///home/andrea/kicad_sources/kicad-doc.bzr/) => http://bazaar.launchpad.net/~kicad-developers/kicad/doc/: Not a branch: “http://bazaar.launchpad.net/~kicad-developers/kicad/doc/”.

If I try to connect to that address through the browser, I only obtainn a “Not Found, The resource could not be found” message.

Does the location of the docs files in launchpad have been changed, so the script needs to be updated?



It seems that kicad is now moving from launchpad to git(github), and the doc repository is not available at its location.
Eventually maintainer of kicad-install will need to adjust the repositories or better - use the new git-based ones.

To solve the issue for now:

edit the kicad-install.sh file and change this line:




This should help.


1 Like

Thank you for your help.
In order to be able to update Kicad, in addition to your suggested modification I had to rename to .old Kicad-doc.bzr as it seems that the command bzr up looks iside that directory to retrieve the address of the repository and does not rely on the DOCS_REPO variable.
Now I am updated to build 6225.
In case the kicad team will migrate the entire project to git, I hope they will supply a new version of the script, as, examinig the script, I guess that once known the right repositories to use and the necessary git commands, it should not be difficult to modify the script.

Thank you again

I did a clean install (on a chromebook with ubuntu) yesterday and changing just the variable worked worked for me.

Likely in your case the fact that you had older repository around from previous install is what caused the need to rename (or remove it).

Yes, you’re right I was updating, that’s why I had to rename kicad-doc.bzr.

Thank yoiu again for your help

I ran in the exact same problem. I followed your solution @kubatyszko and it worked fine. But now I got an error and I can’t find a solution.

[100%] Building CXX object pcbnew/CMakeFiles/pcbnew_kiface.dir/__/common/base_units.cpp.o
Linking CXX shared module _pcbnew.kiface
/usr/bin/ld: ../../boost_root/lib/libboost_system.a(error_code.o): relocation R_X86_64_32 against `.rodata.str1.1' can not be used when making a shared object; recompile with -fPIC
../../boost_root/lib/libboost_system.a: error adding symbols: Bad value
collect2: error: ld returned 1 exit status
pcbnew/CMakeFiles/pcbnew_kiface.dir/build.make:6106: recipe for target 'pcbnew/_pcbnew.kiface' failed
make[2]: *** [pcbnew/_pcbnew.kiface] Error 1
CMakeFiles/Makefile2:1313: recipe for target 'pcbnew/CMakeFiles/pcbnew_kiface.dir/all' failed
make[1]: *** [pcbnew/CMakeFiles/pcbnew_kiface.dir/all] Error 2
Makefile:137: recipe for target 'all' failed
make: *** [all] Error 2

I also try to complile it from the source. But i get the exact same error. Perhaps you guys have any ideas about this?


Somehow I think I found a way to solve this error. .here is the post