Unable to select a text editor

I am new to kicad and i am still exploring the software itself. I was trying to configure the text editor on the preferences menu but i always receive the message that the command could not be found.


I have tried several text editors, and some of them are not shown in the file browser.

The full command that i am using is:
“/usr/bin/flatpak run --branch=stable --arch=x86_64 --command=gedit --file-forwarding org.gnome.gedit @@”, and it works fine on terminal.

I am using Fedora 37 and the kicad 7.0.1. Does anyone know a workaround for this issue?

This is my kicad version info:

Application: KiCad x86_64 on x86_64
Version: 7.0.1, release build
wxWidgets 3.2.2
FreeType 2.12.1
HarfBuzz 5.2.0
FontConfig 2.14.1
libcurl/7.86.0-DEV OpenSSL/3.0.8 zlib/1.2.12 nghttp2/1.52.0
Platform: , 64 bit, Little endian, wxGTK, gnome, wayland
Build Info:
Date: Mar 11 2023 21:04:29
wxWidgets: 3.2.2 (wchar_t,wx containers) GTK+ 3.24
Boost: 1.81.0
OCC: 7.6.3
Curl: 7.86.0-DEV
ngspice: 39
Compiler: GCC 12.2.0 with C++ ABI 1017
Build settings:

Hi Luri – welcome to kicad!

I don’t know what the text editor in kicad does, as I don’t think I have ever seen it open while using kicad, but my pref is simply set to /usr/bin/gedit (which you can enter into the terminal to verify it is installed):

Again, I have no idea whether it is even needed.

I think there is a deficiency in how that setting is parsed, I seem to recall that in another thread somebody couldn’t run an editor path with space in it. This is exacerbated by your flatpak situation where you need a command line instead of just an editor path.

You could just leave the setting alone, I don’t recall ever needing the text editor. Another workaround is to write a shell script that invokes your command, appending any arguments.

Hi @Iuri, that is definitely a bug if you can’t use a flatpak editor as a text editor. If you can, please report this on GitLab so we can look into it and try to fix it.

As a workaround, you can try using the xdg-open command to use the system default text editor. That should launch a FlatPak text editor if it is set as the system default.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.