Unable to find segment with endpoint


I am new to this forum,

I am making a shield for an Arduino Mega with extended sides to fit all my components.

When I try to check over it in 3D viewer though, I get an error message like this:

Unable to find segment with endpoint of (202.43292 mm, 128.04394mm).
Cannot determine the board outline.This text will be hidden

I also tried plotting it as a Gerber and when I opened it with GerbVeiw, it was just blank.

I have zipped up the files and they are at this link: (hope it works)
https://drive.google.com/file/d/18YZRU72a1-1smJAWIgmcAkyRIWDSvnT8/view?usp=sharing -Edit

Thanks for your time!

It sounds like your edge layer drawing isn’t closed. Is it an unusual shape? I know some versions of Kicad had trouble with some shapes. People are reporting that 5.1.6 is close to being released and has some important bug fixes.

I am using 5.1.5 but the board is a pretty unusual shape. I will check the edge layer and see if I can spot anything wrong.

Run the DRC. It will point out problems on the edge cuts layer.

Put your cursor at (202.43292 mm, 128.04394mm) (absolute values) and see what’s happening there.
As @hermit says, board outline must be closed shape, otherwise you’ll get errors like these.

I don’t feel this is a good way to share files - it asks for my email address to send the file there, and I don’t even know what’s the file size in advance.


Okay, I will edit the initial post and put a Google Drive link there instead.
(I can’t attach files yet because i’m a newbie.)

As Rene_Poschl said, I ran the DRC,
It turns out that there were 2 lines that didn’t quite line up and I had to zoom RIGHT in to see it and it’s all okay now. :smile:

1 Like

You will receive more privileges for this forum if you read some threads for some time.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.