Unable to Create Track to Slot

I have a custom footprint where I have created a plated slot by overlapping plated holes. Only the central hole has a pin number.

When I start to create a track to it it highlights as expected, but KiCAD won’t create the track regardless of where I click on the slot.

Any ideas how I can get this to work? KiCAD 4.0.7. Thanks!

Have you made this slot by overlapping many tht pads? There is an option for oval pads with oval “drills”.

Although Rene idea is more elegant, if you want to keep the 5 holes, give the same pin number to all of them.

Thanks! Numbering all the THT pads to ‘1’ did the trick. Will keep the oval drill option in mind for next time.

Check with your manufacturer if they likes your way of making a slot. Placing drills that close can lead to drill breakage. (drill tries to wander into the already drilled hole -> drill bends -> drill breaks)

Slots should ideally not be drilled but milled.

1 Like

Good point. They specify this method so I think they manually convert to a milling operation when they see it. I will also add a note somewhere for them.