Unable to change footprint for a symbol

I have just changed to KiCad 7 from KiCad 6 - which I last used over a year ago so I have probably forgotten a few things.

I have a schematic design, and used the footprint assignment tool to assigned footprints to all the parts. Unfortunately a mistake was made and one part had the wrong foot print - right number of pins, wrong layout.

So, went back to the schematic editor, assigned the right footprint in the footprint assignment tool, saved and closed the schematic editor. (seems there is no explicit ‘create netlist’ stage now?).

Back in the PCB editor, doubled clicked the part, clicked ‘update footprint from library …’, followed it through, and … nothing changed.

Then I went back and did it again, but this time explicitly changed the footprint, and that worked.

But, shouldn’t it have automatically picked up the changed footprint once I had changed it in the footprint assignment tool?

You have to promote the changes made in the schematic to the pcb editor.
For this use Tools–>Update pcb from schematic. (this replaces the older “create netlist” stage).
Be sure to set the checkbox “Replace footprints with those specified in the schematic”.

On the other hand your command “update footprint from library” was not necessary (in this case).

Netlist was used in KiCad V4.
In KiCad V5 you had “Update PCB from Schematic” what now (V7) is “Update PCB with changes made to schematic (F8)”.

I don’t use footprint assignment tool so don’t know if the following is possible: what if you (by mistake) select wrong footprint and it was automatically updated at PCB with all its consequences.
In my opinion it is better if you after making all changes have a chance to once more verify all your changes before you let program to propagate it to PCB.

Thanks, I sort of got it right.

There doesn’t seem to be a “Replace footprints with those specified in the schematic” tick box.


Ah, yes there is, was looking in the PCB editor tool instead.

When I did it, I ended up with two footprints on the PCB - the old and new. Deleted the old one and is OK now.

When I did it, I ended up with two footprints on the PCB

For this usecase you should enable the checkbox “Delete footprints with no symbols”.

My recommendation is the following setting (for normal usecases):

Thanks, your comments are extremely helpful.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.