Ubuntu PPA trouble (Installing KiCad 4.0.x stable in Ubuntu 14.04)

I try to use latest stable release on ubuntu 14.04 bit run into trouble.
The default kicad on ubuntu install is from year 2013 (don’t like it)

If I add ppa ppa:js-reynaud/ppa-kicad
then I got working nightly build but it’s unsafe to run it for production

So I tried recomended stable ppa ppa:js-reynaud/kicad-4
And got into trouble. The kicad-common and docs are version 4.0. and kicad itself from year 2013. Seems that there is something wrong with ppa?

Here are screen shots for each install from synaptic manager.



seems that ppa:js-reynaud/kicad-4 is broken. There are no kicad entry at all.

I edited your title in the hope that someone knows something.

If you do not hear anything here maybe either contact the owner of the ppa (if this is possible) or try your luck over at the bug tracker.

[edit by Joan] @jsreynaud, @bobc

1 Like

Maybe ppa:js-reynaud/kicad-4 is somehow updating from 4.0.6 to 4.0.7 and will be available soon.

Rene thanks for making title more clear.

I checked today and ppa:js-reynaud/kicad-4 is changed.
Now the entry’s are:

kicad 4.0.7+e1-6374~58~ubuntu14.04.1 js-reynaud (12 hours ago)
kicad-doc 4.0.7+e0+1191~16~ubuntu14.04.1 js-reynaud (12 hours ago)
kicad-doc-pkg 4.0.0-1rc2.201511192029+845~8~ubuntu14.04.1 js-reynaud (2015-11-19)
kicad-i18n 4.0.7+e0.201707251705+956~1~ubuntu14.04.1 js-reynaud (12 hours ago)
kicad-library 4.0.7+e0+1139~3~ubuntu14.04.1 js-reynaud (12 hours ago)
kicad-library-pkg 4.0.0-1rc2.201511182116+576~1~ubuntu14.04.1 js-reynaud (2015-11-18)
wxpython3.0 Adam Wolf (2015-09-23)
wxwidgets3.0 3.0.2-1~ubuntu14.04.1~ppa1 Adam Wolf (2015-09-23)

So the ppa is still not usable as there are mixed 4.0.7 and 4.0.0
If I try to install of course I got error like that:

slavko@podstresnik:~$ sudo apt install kicad kicad-common
Reading package lists… Done
_Building dependency tree _
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
_ kicad : Recommends: kicad-library but it is not going to be installed_
_ Conflicts: kicad-common but 4.0.0-0rc2.201511171652+6189~33~ubuntu14.04.1 is to be installed_
E: Unable to correct problems, you have held broken packages.


On PPA there is no kicad-common package to install. Please install kicad only with
apt install kicad

you can additionally add the locale you want:
apt install kicad kicad-locale-XX



…now I fell stupid.

It works. Thanks