Two problems, libraries on wrong drive and won't let me update the pcb from the schematic

Hi,
I have come up against two problems.
Firstly I have changed the drive address, it was the H: drive, now it is the J: drive.
When I first open the Kicad it still has the libraries and templates on the H: drive which it can’t find (they are now also on the J: drive). I can alter this by going to preferences/configure paths and changing the drive paths but I get a box saying
‘This path was defined externally to the running process and will only be temporarily overwritten’
How can I permanently overwrite it?

Secondly, I have opened a new project that I have simply called kicad (I want to save it with other files about my project so ‘kicad’ just tells me it is the kicad file for the project in the directory full of other project info).
I now have a list of files in the kicad shell (is that what the first page that loads up is called?)
The directory in the left column is kicad.pro with sub directories kicad.kicad_pcb, kicad.sch, _autosave-Kicad-cache.lib,_autosave-kicad.pro and _autosave-kicad.sch
So I know I have produced a project.
It is quite a large schematic.
I have annotated it successfully and assigned footprints successfully but when I try to update the PCB from the schematic I am told

‘I cannot update the PCB because the schematic editor is opened in stand alone mode. In order to create/update PCB’s you need to launch Kicad shell and create a PCB project’

I thought that was what I had done?
Do I now lose my schematic work or can I import it into a PCB project and how do I do that?

I thought it was called the “Project Manager”, but when I simulate the problem you describe later I also get:

KiCad depends on the base name of the project, the root schematic and the PCB file to all have the same name. I assume you have been doing some reordering or renaming of filenames and made a mistake here.

I hope you have a recent backup, or else make one now before you proceed.

I generated the message above by first opening a schematic file in the schematic editor (so not though the project manager (shell?). For you, I assume KiCad got confused because you made some error with file renaming.

Next: Please do not call your project “kicad”. It invites confusion. Suppose you have printouts of a bunch of schematics, and they are all called “kicad”. Use descriptive names for your projects.
kicad.sch
What KiCad version are you using? Files with names like:
kicad.pro
kicad.sch
_autosave-Kicad-cache.lib
_autosave-kicad.pro
_autosave-kicad.sch

are syntax from KiCad V5 or older. Starting from KiCad V6, KiCad uses these extensions:
.kicad_pro
.kicad_prl
.kicad_sch
.kicad_pcb

If a KiCad V5 (or earlier) version is opened in KiCad V6 (or later) and saved, KiCad saves the files with the new extensions. The old files are left behind and KiCad does not use them anymore. They can be deleted to cleanup your project, but you have to do that yourself. (But only delete them if your project is in good shape. Have a decent backup strategy in place).

Your problem also becomes more complex with you H: drive and J: drive. KiCad has had some problems with network shares, but that is a topic I do not know much about.

You can probably “fix” it by editing one of KiCad’s configuration files with a text editor. I’m not sure where KiCad saves those paths though.

This is also confusing:

I assume you are mixing up “directory” with “file”, but that assumption has a big question mark.

There is no reason to panic (yet). I’m quite sure your project can be recovered. But start by stating your full KiCad version (from “… / Help / About KiCad / Copy Version Info” and a directory listing of the project with all file names (and probably file sizes too).

Thanks for the reply.

I have not used the Kicad for a while. It is on a network drive and I am sure it worked ok before. I think I must have just done something wrong.
I opened up a project, I only want to produce a picture of the prototype board I have made containing a nano, lcd and a few other items to add to the same directory the arduino files are in so to just call it Kicad would suffice and show it as the Kicad file when I look at the directory.
In replying to this I am switching back and forth with the Kicad program to get my facts right. I went back to the sch and clicked on tools/update the PCB from the schematic to see what I got and it worked?
I now have a jumble of items on the PCB page that need laying out in a neat format so I don’t know what happened last night?
For some reason even though it said last night that any drive changes would be temporary it seems to have gone back to the drive I altered it to last night so both problems seem to have fixed themselves overnight?
I am using version (5.1.7)-1

I think I am, the directory in the left box of the Project Manager is Kicad.Pro and the files are the ones I called directories above.

I very rarely use it now so don’t think there is any need to update the version at this point.
I will continue to get my copy to put in the directory for my board and see if anything else alters.
Thanks for the time you have spent.

Kicad is still evolving rapidly. New, and changed, features are adopted rapidly by the users of this forum.
How Kicad used to work gets rapidly lost from the memory of these denizens.

Useful answers to questions are much more likely to be given if asked about current or near current versions of this software.

KiCad V5 had a very big handicap in the implementation of the [Project]-cache.lib file. It is a nuisance to deal with, and it’s easy to make errors with it, So I recommend to update at least to KiCad V6.

Between your very old KiCad-5.1.7-Release and now is almost 4 years of development. Very many bugs have been fixed in between. And I do not mean hundreds, but several thousands. New bugs have also been introduced (and fixed).

I understand if you don’t need the newest and greatest KiCad version, but as jmk already mentioned, KiCad gets improved so quickly that people tend to forget the peculiarities of a 4 year old KiCad version. My recommendation is to keep relatively up to date with the “previous” stable KiCad version, and with the highest bug fix number. Currently that is KiCad V7.0.11.