Turn off snap feature in v7?

I am enjoying many of the new features of KiCAD 7!

It seems that the object snap has been improved in v7. Most of the time it is very helpful, but once in a while it is forcing the location of something I don’t want snapped. My work around is to manually enter the location in the position fields of the properties dialog for that object.

It would be a nice improvement if, while moving an object, you could temporarily disable the snap feature. I have looked and did not find a way to do this. I assume it does not exist?

At least in Board Editor, if I select a via and move (shortcut M), if I then press the Ctrl button while moving with the mouse, the snapping to grid is switched off and I can place the via at an arbitrary point independent of the selected grid.
Is that what you are thinking of?

Thank you for your reply. In this case holding the Ctrl button while moving the object with the mouse does not turn off the snap that is occurring. For a little more detail in the latest particular use case, I am moving a logo that is considered a footprint. I have an array of vias that are part of a counterpoise for a radio that are also individual footprints. The center of the logo tends to want to snap to the center of the vias. Pressing the Ctrl button does not seem to change anything regarding this.

Version: 7.0.1, release build on Windows 10

Seems to me that sometimes ctrl does not disable snap but if I zoom in further it does. Can’t reproduce it at the moment but have seen it from time to time.

CTRL: disable grid snapping
Shift: disable object snapping


That does it! Thanks for the reply. It would be nice to be able to find that secret somehow in KiCAD… but at least it is posted here now!


Awesome, I will have to remember to search there next time too.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.