Trying to share color scheme between computers

Seems like a stupid question, but I am trying to share schematic color scheme between computers. I have already copied my .json file:

image

But I cannot figure out how to select it?

Then…I managed to select it but it is not called what I called it; rather it is called “Something Else”?

image

That Computer is now turned off, but it is running version 7.09 under Windows 10.
Now in my previous computer, I see that the same .json filename still works the same way. I called it BobZ2 but KiCAD calls it “Something Else”. Not a serious problem, but it certainly raises (???).

I’m not ambidextrous, so I only have and use one computer. :slightly_frowning_face:

“I’d give an arm to be ambidextrous” :rofl:

Let’s just wing it. Don’t cause a flap.

From @jmk Private Message:

I have noticed I cannot rename a theme, but if I load a theme and then click new theme I can create a theme with a new name that is a duplicate of the theme present when clicking new theme.

Doing that and then deleting the theme with the old name effectively changes the theme name?

Hmmm. That works:

  1. Load the theme which KiCad has called “Something Else”.
  2. Create a new theme (but name must be new; not one already in the folder).

But…I wonder why does it work that way?

When you put the new theme into the “colors” folder while KiCad is still running, it will not update the list. I always had to restart KiCad to see the new theme in the list. Maybe that’s related? Did you try to simply restart KiCad after putting the theme into the folder?

Thanks. My first error was that I did not restart KiCad.
It is after restarting KiCad that the new theme appears as “Something Else.” This even though the file is named BobZ2.

If I try to create a new theme named BobZ2 it will not let me do so because it says there is already one with that name. That filename is in the folder, but KiCad refuses to call it that.

So what I need to do is select “Something Else” and then “create a new theme” called BobZ3 assuming that there is no file with that name already in the folder. This approach was recommended by @JMK and it seems to work.

OK this is all workable, but I wonder why it needs to work that way? When I copied BobZ2 into the folder, why couldn’t KiCad just accept that name?

The answer to that is above my pay grade.

Maybe if you change the category to Software or @ one or two developers, you may attract a suitable pay grade member, who can supply a definitive answer. :smiley:

@craftyjon @JeffYoung Do you guys know why this is, or do you know who would know, or do you know who would know who would know who would know? :slight_smile:

Thanks,

BobZ

Are you able to share to color scheme to check?
There is a meta part in the json file which should have name in it, for example:

  "meta": {
    "filename": "eagle-dark",
    "name": "Eagle Dark",
    "version": 3
  },

Open json file in a text editor and check it yourself

Looks like @greg_m knows (or knows a guy who knows…) :slight_smile:

I know the guy who knows the guy who knows the guy who knows :wink:.

Either way it would be good to see the meta block of the json file as this is responsible for the displayed name.

Thanks, Indeed! Thar she blows!:

“meta”: {
“filename”: “user”,
“name”: “Something Else”,
“version”: 5

I don’t think I would have chosen that name (> year ago) but that is not impossible.
I started using KiCad with 2014 vintage computer A which is now up in my lab.
I coped my settings (including the .json file) to this 2022 vintage computer B.
Last week I copied them to my employer’s computer “C”.

It seems that KiCad tends to choose that name?
BobZ2.json (7.6 KB)