Trying to draw an antenna but it incorrectly repells zones

Hi

I am trying to make an antenna footprint and it was straightforward until I use it in my design. The footprint has 2 pads, 1 and 2. In my Schematic both are connected to /GND, eventhough the /GND zone is repelled by the footprint being placed. Is this a bug or did I misunderstand something?

Kind regards
Jens

And here is the problem, the forum did not allow me to post more than one image

I am planning to do RFID antenna footprint, but didn’t tried it yet.
As I know the key is to copy the solution from Net-tie footprints. You should find them in KiCad library. I never used them. If you didn’t know that than think about it. If you knew it than I don’t know what is the source of your problem.
Others probably can be more helpful.

Perhaps KiCad thinks that both ends of the antenna are the same net (because they are). So you cannot connect them on different nets. How to confuse KiCad?

Fixed. Post away…

Thanks @hermit

@LM21 makes sense, I now tried to add a connection so that both ends of the antenna would be /GND, but this did not seem to help at all unfortunately. Still the same problem

@Piotr I also tried the NetTie idea, did not hear about it before, but it seemed to not make any improvement either. And I would think that the Ground Loop component I used would have a similar effect anyway?

Any other ideas?
Kind regards
Jens

Looking at big GND pad on the right and how GND zone is connected to it … may be:

  • zone don’t connect to your antenna just because it makes thermal clearance there,
  • parameters for thermal spoke width make connection impossible.

Where from are those thermal connections to that big GND pad so wide. If zone tries to use the same width tracks to connect to your antenna it can be not possible to be done.

I don’t think that is the problem either. I have settings on GND and VDD to be quite wide.

But I think I managed to solve it with an ugly workaround. I recreated the antenna to be a single polygon Pad and I changed the schematics to be a simple antenna with only one end, which I also connected to GND.

Ugly, yes I think so, but it seem to make the desired result. I guess I will partly put the DRC out of order so maybe there are issues that I would not spot when doing it like this?


I may not understand your problem so, this may be worthless…

I created a Footprint with Two SMD Pads placed on a Filled Polygon Pad.

I created a Symbol for it with Two Pins.

Added Net labels (two GND labels) and wired them up.

Pushed them to the PCB and no problems connecting…

Also, I did Not have a problem when connecting to Two Pins (on connector when I set them to the same GND Net (not shown)

Perhaps you have a ‘Walk-Around’ issue that can be resolved by careful inspection and checking the DRC Walk-Around settings…

How have others done this. I think that there are quite lot of microwave shapes and PCB antennas in KICad, so this should be a familiar problem.

@BlackCoffee I have not tried to directly connect the antenna with tracks, but the antenna intersected a zone with the same net /GND and I would expect the zone to merge with the antenna, but ut did not, it repelled the antenna and put distance to it even if it was the same net.

Anyway my particular problem is solved I think since I made a pad of the antenna and only have one pad. So it will be correct I think, but still odd that the original idea would not work.

Good that you have a solution.

This Example uses a Filled-Zone as an option (perhaps for future)…
• I drew a Filled Polygon
• Right-Click, Create from Selection> Create Zone from Selection

• This time I used THT instead of SMD (Pad type doesn’t matter)
• Set the Nets to GND
• In the Schematic, I connected to Symbols of Pads (doesn’t matter, could use previous 2-pin connector). I didn’t bother making Pad Footprint so, I associated them with the Connector)

FYI - you set the Walk-Around and Shove in the Interactive Settings Panel

1 Like

Try selecting your pad, go to “Clearance Overrides and Settings” and look for “Pad Connection”. It should be selected as solid. From time to time it is set to “none” by default with custom pads and then it won’t connect to zones.