Trying out 5.0 in linuxmint... not going so good


#1

First start of eeschema, I get a message asking to configure some Global Symbol Library Table with a recommended option greyed out. No help documentation is popping up either… see attached screenshot.

For the help stuff, “kicad-docs” wasn’t found in the PPA and neither was “kicad-docs-US” or “kicad-docs-EN” or anything that I thought made sense.


#2

The library package is separate (This is standard in most linux applications that include large amounts of data)
Install the library package and then either delete the created lib table (in your user profile under ~/.config/kicad/sym-lib-table) to get this promoted again when starting eeschema.

Or use the library manager found under eeschema -> preferences to manually add the libs that should then be found under /usr/share/kicad/library/ (Use the browse button to add libs. A file browser opens. Select all .lib files that are in the mentioned directory. shift plus left click or crtl plus left click for multiple selections.)


#3

Thanks for the response Renee,

When I installed Kicad, I installed the kicad-libraries package. However /user/share/kicad does not have a “library” folder.

Also - how do I get the missing documentation installed?


#4

I would guess there is more than one package. Use your package manager and search for kicad* This should list all available packages.
Make sure you select the version 5 packages (It might be that some version 4 packages are still available)


#5

For the DOCS…
The js-reynaud ppa says:

  • kicad-docs-XX: documentation in your language. Same remark than kicad-locale-XX

This should be corrected to “kicad-doc-XX”

For the LIBRARIES…

In the Software Manager, kicad-libraries is installed (version 5.0.0-stable-…). The description is that this is a “meta package to allow a full installation for all kicad libraries - footprints - symbols - packages”.

There are separate items that aren’t installed, kicad-footprints, kicad-packages3d, kicad-symbols, kicad-templates. Do these need to also be manually installed?

On the PPA website, kicad-libraries is described as “a virtual package that will recommend you to install footprints, symbols, templates and 3D”. I can’t understand what this means, but I interpreted it as meaning that it installs footprints, symbols, templates and 3D and manages them for me. No?

Thanks for your time. I used KiCad on a very large board about 6 years ago and now designing a new, more complicated product… I just built a new computer to run KiCad faster and I’m looking forward to KiCad 5’s improvements.


#6

These packages will contain the library files them selfes. They must be installed for you to have the official library. (you could also manually download the libs and setup your system that way but it will be a lot easier to install the packages using the package manager)


You are right the kicad-libraries package should install the 4 packages listed above. But it seems this mechanism does not work. Maybe report this over at the bugtracker.


#7

Thank you.
So if I install kicad-footprints, kicad-packages3d, kicad-symbols and kicad-templates from the PPA through the Software Manager… is this functionally the same as if kicad-libraries functioned properly? Or am I missing out on anything?


#8

I would think so.

Just remember that kicad already setup a sym-lib-table as i explained above so it will not ask you again if it should setup the default. (How to solve this is already explained above)


#9

Hello,

I had the same experience with MINT 18.3 and KiCad5.
It was a “fresh” system that never had a KiCad4 installation !
The SW ran fine but the libraries were missing. In the terminal I read the new package name: libraries instead of library. But the installation still didnt work.
I guessed, the new V5 structure might still not be complete and - after activating the 5.0 ppa - used the SW-managers library install. Now everything is OK, I have the new libraries.
Of course I hope in the future the terminal-based installation as described on KiCads website will always work stand-alone for my system.

I love to use LINUX instead of windows but I will never understand why a windows user can simply download an exe and say “I want it all” while the LINUX nerd :wink: has to go through a painful file-by-file installation. :cry:


#10

The libraries change constantly. I have a short script to update them via git. The *nix philosophy is to have different files for different things.


#11

Hi hermit,

When you say “libraries change constantly”, that sort of scares me away from updating the libraries while working on a project. Is it just that the libraries are being added to constantly (that’s fine), but I’m apprehensive about incorporating changes in footprints and stuff when I’m already successfully using them… seems like I’d just be introducing the possibility of breaking my project. Am I totally off base?


#12

Mainly this. I don’t believe the librarians change things in working libraries. They did do some revamping of old symbols for the V5 update. People do add to the libraries via git so new stuff does get added.


#13

Right now we are careful not to change too much stuff that would break existing installations as we want our updates to be included in 5.0.1 and 5.1. After that we might again open up the lib development for all changes.


#14

That puzzles me as well. It seems like there should be a single install and go package for the stable release at least. Linux (et al) seem to have a whole array of different packaging schemes as well as distro policies.


#15

That’s why many of us advise to copy the official libraries to a different directory in our local disk, preventing unwanted updates.


#16

More like have personal libraries in a different place. These could be parts you make and parts you have used/vetted. They could also be project specific. I haven’t played with 5 much yet but 4 maintained a project cache of symbols and footprints if I remember correctly. This allowed you to zip up the directory and send it to someone whose libraries may be in a different place.


#17

I am also using MINT 18.3 Sylvia and am looking to upgrade to 5.0 but have not taken the plunge yet.
Can you give a quickie lesson on how to use the Software Manager and PPA to do this?
I’m not real up on this Linux yet. I think I did install previous version with PPA and rememger adding something for Software Manager to find KiCad.
Thanks, :wink:
OtG


#18

Hi Oscar,

I can not recall every single step from my installation and right now I am sitting in front of a win10 slavery station :unamused:
But basically you should do this:

  1. DO NOT install from the SW-Manager as it comes with MINT. In the past this installation went totally wrong.
  2. I had a fresh MINT installation WITHOUT KiCad4. Some people here seem to experience difficulties when NOT removing V4 previously ?
  3. Copy the repository address (ppa) from the KiCad website and insert it into the SW-Managers list of external ppa(s).
  4. Use the steps from the KiCAD website, copy them into a terminal …
  5. Repeat the last step for libraries, locals and docs as mentioned in the description.
  6. for me the libraries installation did not work (there was a message that its now “libraries” instead of “library” or similar - I tried that too) , no files to be found on my PC. But as I had included the KiCad ppa (3), I could now use the MINT SW-Manager to install the libraries and it installed the new V5 ones.

All this is the reason why I lamented about having no single “give it to me package” :smiley:


#19

Documentation for installation of KiCAD 5.0.0-stable onto Linux Mint 18.1 and Ubuntu/apt based Linux systems

(Current as of 15-OCT-2018):

In case you missed it in the title, these instructions are for Ubuntu Linux systems and obviously require the use of a terminal :slightly_smiling_face:

tl;dr [en]: sudo add-apt-repository ppa:js-reynaud/kicad-5 && sudo apt update && sudo apt install kicad kicad-libraries kicad-doc-en && kicad

tl;dr [es]: sudo add-apt-repository ppa:js-reynaud/kicad-5 && sudo apt update && sudo apt install kicad kicad-libraries kicad-locale-es kicad-doc-es && kicad

tl;dr [ru]: sudo add-apt-repository ppa:js-reynaud/kicad-5 && sudo apt update && sudo apt install kicad kicad-libraries kicad-locale-ru kicad-doc-ru && kicad

@marchinghome Late response but in the interest of posterity…

  1. Add the PPA for KiCAD 5 stable:
    sudo add-apt-repository ppa:js-reynaud/kicad-5

(Note: this PPA will have higher priority over KiCAD 4 but will not remove it from apt’s database)

  1. Update your system:
    sudo apt-get update

  2. Install KiCAD (apt should pull in any dependencies auto-magically)
    sudo apt install kicad

  3. Kicad symbols, footprints, 3d packages and templates all come in separate packages but can be installed at once with a “meta package”. Install the meta package for KiCAD 5.0 libraries:
    sudo apt install kicad-libraries

    …Or install them as individual pacakges:
    sudo apt install kicad-symbols kicad-templates kicad-footprints kicad-packages3dy

(Note: that the KiCAD 4 libraries are called kicad-library and they are still in the apt database, don’t install them! :blush: if you do, run
apt remove kicad-library
to uninstall them.

  1. Install the documentation and locale for your language(s):

(Note: English (EN) is the default language locale for KiCAD but you do need to install the documentation packages seperately including English)

  • ([CA] Catalan):
    sudo apt install kicad-doc-ca kicad-locale-ca

  • ([DE] German):
    sudo apt install kicad-doc-de kicad-locale-de

  • ([EN] English):
    sudo apt install kicad-doc-en

  • ([ES] Spanish)
    sudo apt install kicad-doc-es kicad-locale-es

  • ([FR] French):
    sudo apt install kicad-doc-fr kicad-locale-fr

  • ([IT] Italian):
    sudo apt install kicad-doc-it kicad-locale-it

  • ([JA] Japanese):
    sudo apt install kicad-doc-ja kicad-locale-ja

  • ([NL] Dutch):
    sudo apt install kicad-doc-nl kicad-locale-nl

  • ([PL] Polish):
    sudo apt install kicad-doc-pl kicad-locale-pl

  • ([RU] Russian):
    sudo apt install kicad-doc-ru kicad-locale-ru

This writeup is an expanded version of Jean’s original announcement on the KiCAD Launchpad:

https://launchpad.net/~js-reynaud/+archive/ubuntu/kicad-5