Trouble with Replacing Footprints

Hi, I am having a problem with replacing footprints that have a centering cross and target on the Courtyard layer. I have edited the footprints to delete the cross and circle, went to the schematic Assign Footprints function where I reassigned the altered footprints, did an ERC with everything okay, redid the netlist, and then went to the PCB. In Pcbnew I first tried the Update PCB from schematic function, but that didn’t work. I then ran the Load netlist function, and that didn’t work. Although the function says changes were made the cross and circle still appear on the courtyard layer and sure enough the DRC still says “Footprint has incorrect courtyard (not a closed shape)”.
Here is my system setup report:
Version: 5.1.3-ffb9f22~84~ubuntu18.04.1, release build
wxWidgets 3.0.4
libcurl/7.58.0 OpenSSL/1.1.1 zlib/1.2.11 libidn2/2.0.4 libpsl/0.19.1 (+libidn2/2.0.4) nghttp2/1.30.0 librtmp/2.3
Platform: Linux 4.15.0-55-generic x86_64, 64 bit, Little endian, wxGTK
Build Info:
wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 3.22
Boost: 1.65.1
OpenCASCADE Community Edition: 6.9.1
Curl: 7.58.0
Compiler: GCC 7.4.0 with C++ ABI 1011

Build settings:
What do I need to do?
–Regards, Larry

What settings did you choose in the update pcb from schematic dialog? (A screenshot perhabs?)

Did you save the footprints with new names and change the attached footprint names of the symbols in the schematic?

I did the “Keep existing symbol to footprint associations” along with “Update footprints”. That didn’t work so I did the “Re-associate footprints by reference” along with “Update footprints”. That didn’t work either.

No, I do not save the footprints with new names. I save the edited footprint, after deleting the cross and circle target from the front courtyard.

Could you attach a screenshot, an example board file and the footprint file you think you are trying to update it to.

You have to use Update Footprints from Library in pcbnew, either from the context menu of from Tools menu.

The user interface texts are just plain misleading. “Update footprints” checkbox doesn’t refresh footprint files from the library. Unticking it allows keeping old footprints on the board even after symbol/footprint associations have been changed (i.e. footprint names in the symbols’ properties have been changed).

You really need to save your edited footprint in your own, personal library. If you simply edit the stock KiCad footprints, the next time you update KiCad you risk overwriting all your hard work.

1 Like

That is a tall order. It will take me a while to accomplish.

What do you mean by “context menu”? If you mean RMB after selecting with LMB “Update Footprints from Library” is not an option. I did go to the tools menu after LMB selecting one of the footprints, then selecting Update Footprints from Library", then clicked the radio button for “Update footprints matching reference:”, then went to the box and put in the ref des of the plated thru hole I was working with, clicked on “Apply” and the footprint disappeared!?

Yes, all this work on footprints (land patterns) is in my own personal library.

Okay, here is a screenshot of my PCB. The one particular footprint I am trying to change is ref des NPH1 (non-plated thru hole):

Here is the board file:
Me10101-1.kicad_pcb (379.4 KB)

And here is the footprint I am trying to update to:
MTGNPH300Z400.kicad_mod (861 Bytes)

There are two options. The tool menu with its update footprints from library option. And when right clicking onto a footprint the update footprint entry.

1 Like

Context menu is the “Right Mouse Button” menu (although sometimes it may be the Left Button depending on the setup) for an item. Select the footprint first then open the context menu on top of it. Open “Update Footprint”. Choose “Update selected footprint” or some other option and Apply.

But what happened to your footprint and why? Congratulations, you just found a bug! It appears that opening the dialog from the Tools menu is buggy. It moves the footprint, possibly so far that it disappears from the view. I’ll report that.

That’s a nasty bug. Is it new to 5.1.3 or are earlier versions affected as well?

I don’t know, I just tried with a post-5.1.3/pre-5.1.4 nightly build. I suppose few people open that dialog from Tools menu, so it may have gone undetected for a long time.

EDIT: this was a duplicate report after all and the bug appeared after 5.1.2.

1 Like

Hey, Larry. I just noticed that you have radiused the corners of your board. I think you should be OK with small radii like that, but there is a known bug in 5.1.2 that is fixed in 5.1.3 (due to be released RSN as the source is tagged and packagers are building the packages as we speak). The bug causes uncontrolled “explosions” of traces inside circles and arcs of the board outline (Edge.Cuts layer). The temporary fix in 5.1.2 is to move the arcs to an unused artwork layer (so you can still see them), do the routing, and then move the arcs back to Edge.Cuts.

I just thought I would warn you in case you decide to increase the corner radii and wonder why the routing from R1 to R2 explodes on you.

I reported this as a bug.