Trouble in macOS Big Sur 11.12.1 - no layouts

I am new to KiCad, but not to schematic and PCB design. Got my Schematic, plus footprints all done. Figured how to get with Tools -> update PCB from Schematic to a PCB, but there the problem came: there is nothing to see on my PCB screen, actually, it is all ‘white’ (same color as the rest of the screen - like toolbars, sidebars etc.) Tried all kind of zooms, and verified that my x,y coordinates are 0,0.
Now also on the footprint assignment of components in EEschema I no longer see the green footprints against a black background. (I saw them a couple of days ago - but I have never seen a black background in the PCB editor). I run KiCad 5.1.9-0-10_14 for MacOS 10.16 (build 20D74) 64 bit. Oh yes, all schematic DRC and the update to PCB ran without any errors.
In case I tried to upload a screencopy below here

Try setting to Modern toolset (Accelerated) in the Preferences menu or just press Alt + Fn11

2 Likes

Thanks John - that did help; a bit: The background is now black, and I see components and footprints, I can move them, but I do not see the rats-nest wires.

Ok re-starting shows the rats-nest. (before nothing came up also not after toggling the ratsnest button)…

John: thanks for the help!