Trouble after installing Kicad 5.0 on my Mac (running macOS Mojave)


#1

Hi everyone,

I just installed Kicad 5.0 on my freshly updated Mac now running macOS Mojave.

But the thing is I cannot properly Kicad as I get some trouble loading the symbols and footprints libraries.
For example, when I run the symbol library editor, I get "Cannot load aliases from library “Altera” (for example). Same thing happens when I run the footprint editor and multiple libraries appear to be empty.

I tried the different RC versions released before the “real” 5.0 one and I didn’t get any problem. But my Mac was running macOS High Sierra at that time.:confused:

Does anyone have the same problem ?

Thanks a lot in advance for helping me :wink:


The next release in 5.0.x series
#2

Sounds like the libraries weren’t installed or the paths are wrong. I know nothing about the MAC installer.


#3

Hi RWIN-

Mojave has multiple problems right now. We’re trying to update our build script to deal with it.

When 5.0.1 is released, Mojave will be supported. Hopefully not too long now…


#4

Thanks for the answer. I guess I should wait until 5.0.1 is released ! :smile: