Translocation Problem with Macintosh Install

Tonight, I downloaded and attempted to install KiCAD on my Macintosh computer. I’m running MacOS version 10.12, so I downloaded kicad-unified-5.1.5-0.dmg which is supposed to be compatible with versions 10.12 and 10.13. When I tried to run the main KiCAD application I got a cryptic message:
“%@” can’t be found
Checking the crash log, I noted that the application had been translocated. This is a Macintosh security measure that is enacted if the DMG archive isn’t signed. Usually, when you attempt to run an unsigned application, the operating system flashes a warning message, and allows you the option of running it anyway. However, this didn’t happen in this case. The workaround was to delete the KiCAD applications from the Applications folder and then run them directly from the DMG archive. This time, the operating system flashed the warning message. I was able to override the warnings and run each one. Note that they didn’t run properly from the DMG archive, but it was sufficient to make the operating system happy. After this, I was able to copy the KiCAD applications to the Applications folder and they now seem to run correctly.

I’m surprised that the distribution DMG was not properly signed, leading to this installation problem.

In any event, I ran across a couple of past posts in this forum where users were having problems that appeared similar (they had attached crash logs that indicated that the application had been translocated) but their issues had never been resolved.

So, I’m posting this in case others experience this problem, and if anyone on the development team reads this, perhaps they could look into the signing of the distribution DMG.

Devs are definitely aware of the signing issue (since 2015 at least) and are working on it but it’s not a simple problem to solve. You can search mailing archive for some discussions about this:

Here is more recent thread:

Also, especially “notarization”.

I guess I’m just a bit puzzled that if it’s been a known issue for five years, then why is there no warning in the installation notes, and why are there no instructions on how to proceed when it happens?

This is the first time (as far as i am aware) something like this has been asked on the forum. So my personal guess is that either something has changed recently with mac or there is another reason why it is rarely an issue (example standard mac setup might not be as strict as yours).

I’m following your workaround and I can’t get it running when copied in Applications folder.
How can I reach the log file?

I can only use kicad if opening the package, navigating to contents/Macos and clicking on kicad

When an application crashes, it usually brings up a message along with a button you can click to view the crash log.

Are you running MacOS version 10.12 (Sierra)? If not, that’s likely the reason why you were unable to get my workaround to work. Each new version of MacOS makes it more and more difficult to install and run unsigned applications.

When I was trying to get KiCAD to run, I tried a number of different things before finding the workaround that I described in the first post. It’s possible that one of those other things that I initially tried may have had a positive effect. Unfortunately, I can’t remember everything that I tried.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.